opensolaris man page for ldi_write

Query: ldi_write

OS: opensolaris

Section: 9f

Links: opensolaris man pages   all man pages

Forums: unix linux community   forum categories

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

ldi_read(9F)						   Kernel Functions for Drivers 					      ldi_read(9F)

NAME
ldi_read, ldi_write - Read and write from a device
SYNOPSIS
#include <sys/sunldi.h> int ldi_read(ldi_handle_t lh, struct uio *uiop, cred_t *cr); int ldi_write(ldi_handle_t lh, struct uio *uiop, cred_t *cr);
PARAMETERS
lh Layered handle. cr Pointer to a credential structure used to open a device. uiop Pointer to the uio(9S) structure. uio(9S) specifies the location of the read or write data. (Either userland or kernel.)
DESCRIPTION
The ldi_read() function passes a read request to the device entry point for the device specified by the layered handle. This operation is supported for block, character, and streams devices. The ldi_write() function passes a write request to the device entry point for a device specified by the layered handle. This operation is supported for block, character, and streams devices.
RETURN VALUES
The ldi_read() and ldi_write() functions return 0 upon success. If a failure occurs before the request is passed to the device, the pos- sible return values are shown below. Otherwise any other error number may be returned by the device. EINVAL Invalid input parameters. ENOTSUP Operation is not supported for this device.
CONTEXT
These functions may be called from user or kernel context. SunOS 5.11 3 June 2003 ldi_read(9F)
Related Man Pages
ldi_aread(9f) - sunos
ldi_ioctl(9f) - sunos
ldi_aread(9f) - opensolaris
ldi_awrite(9f) - opensolaris
ldi_putmsg(9f) - opensolaris
Similar Topics in the Unix Linux Community
Trying to block signal
How to learn UNIX
Free Sun Blade 2k, Ultra 2, Ross Hyperstation 30, cards, memory- Baltimore, MD
What's legal and what's not?
Identify problem with while getopts