opensolaris man page for ldi_poll

Query: ldi_poll

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

ldi_poll(9F)						   Kernel Functions for Drivers 					      ldi_poll(9F)

NAME
ldi_poll - Poll a device
SYNOPSIS
#include <sys/sunldi.h> int ldi_poll(ldi_handle_t lh, short events, int anyyet, short *reventsp, struct pollhead **phpp);
PARAMETERS
lh Layered handle. events Potential events. Valid events are: POLLIN Data other than high priority data may be read without blocking. POLLOUT Normal data may be written without blocking. POLLPRI High priority data may be received without blocking. POLLHUP Device hangup has occurred. POLLERR An error has occurred on the device. POLLRDNORM Normal data (priority band = 0) may be read without blocking. POLLRDBAND Data from a non-zero priority band may be read without blocking. POLLWRNORM Data other than high priority data may be read without blocking. POLLWRBAND Priority data (priority band > 0) may be written. anyyet A flag that is non-zero if any other file descriptors in the pollfd array have events pending. The poll(2) system call takes a pointer to an array of pollfd structures as one of its arguments. See poll(2) for more details. reventsp Pointer to a bitmask of the returned events satisfied. phpp Pointer to a pointer to a pollhead structure.
DESCRIPTION
The ldi_poll() function passes a poll request to the device entry point for the device specified by the layered handle. This operation is supported for block, character, and streams devices.
RETURN VALUES
The ldi_poll() function returns 0 upon success. If a failure occurs before the request is passed on to the device, possible return values are: EINVAL Invalid input parameters. ENOTSUP Operation is not supported for this device.
CONTEXT
These functions may be called from user or kernel context. SunOS 5.11 3 June 2003 ldi_poll(9F)
Related Man Pages
chpoll(9e) - sunos
chpoll(9e) - redhat
chpoll(9e) - plan9
chpoll(9e) - v7
chpoll(9e) - osf1
Similar Topics in the Unix Linux Community
What does this mean?
Study UNIX Kernel
Grep the 'not running' jobs and will send the update in mail with its name(job)
Identify problem with while getopts
Solaris 10 - password complexity not working