opensolaris man page for getq

Query: getq

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

getq(9F)						   Kernel Functions for Drivers 						  getq(9F)

NAME
getq - get the next message from a queue
SYNOPSIS
#include <sys/stream.h> mblk_t *getq(queue_t *q);
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
PARAMETERS
q Pointer to the queue from which the message is to be retrieved.
DESCRIPTION
The getq() function is used by a service ( srv(9E)) routine to retrieve its enqueued messages. A module or driver may include a service routine to process enqueued messages. Once the STREAMS scheduler calls srv() it must process all enqueued messages, unless prevented by flow control. getq() obtains the next available message from the top of the queue pointed to by q. It should be called in a while loop that is exited only when there are no more messages or flow control prevents further processing. If an attempt was made to write to the queue while it was blocked by flow control, getq() back-enables (restarts) the service routine once it falls below the low water mark.
RETURN VALUES
If there is a message to retrieve, getq() returns a pointer to it. If no message is queued, getq() returns a NULL pointer.
CONTEXT
The getq() function can be called from user, interrupt, or kernel context.
EXAMPLES
See dupb(9F).
SEE ALSO
srv(9E), bcanput(9F), canput(9F), dupb(9F), putbq(9F), putq(9F), qenable(9F) Writing Device Drivers STREAMS Programming Guide SunOS 5.11 16 Jan 2006 getq(9F)
Related Man Pages
srv(9e) - opensolaris
srv(9e) - sunos
srv(9e) - centos
srv(9e) - minix
srv(9e) - mojave
Similar Topics in the Unix Linux Community
Help with sed
Compare two xml files while ignoring some xml tags
SQL Script HELP Requested.
How can i enable audit logs for global zone and standard zones?
How to delete blank line/s before and after a search pattern?