opensolaris man page for enableok

Query: enableok

OS: opensolaris

Section: 9f

Links: opensolaris man pages   all man pages

Forums: forum home   forum categories

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

enableok(9F)						   Kernel Functions for Drivers 					      enableok(9F)

NAME
enableok - reschedule a queue for service
SYNOPSIS
#include <sys/stream.h> #include <sys/ddi.h> void enableok(queue_t *q);
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
PARAMETERS
q A pointer to the queue to be rescheduled.
DESCRIPTION
The enableok() function enables queue q to be rescheduled for service. It reverses the effect of a previous call to noenable(9F) on q by turning off the QNOENB flag in the queue.
CONTEXT
The enableok() function can be called from user, interrupt, or kernel context.
EXAMPLES
Example 1 Using emableok() The qrestart() routine uses two STREAMS functions to restart a queue that has been disabled. The enableok() function turns off the QNOENB flag, allowing the qenable(9F) to schedule the queue for immediate processing. 1 void 2 qrestart(rdwr_q) 3 register queue_t *rdwr_q; 4 { 5 enableok(rdwr_q); 6 /* re-enable a queue that has been disabled */ 7 (void) qenable(rdwr_q); 8 }
SEE ALSO
noenable(9F), qenable(9F) Writing Device Drivers STREAMS Programming Guide SunOS 5.11 16 Jan 2006 enableok(9F)