opensolaris man page for ddi_dma_free_handle

Query: ddi_dma_free_handle

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

ddi_dma_free_handle(9F) 				   Kernel Functions for Drivers 				   ddi_dma_free_handle(9F)

NAME
ddi_dma_free_handle - free DMA handle
SYNOPSIS
#include <sys/ddi.h> #include <sys/sunddi.h> void ddi_dma_free_handle(ddi_dma_handle_t *handle);
PARAMETERS
handle A pointer to the DMA handle previously allocated by a call to ddi_dma_alloc_handle(9F).
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).
DESCRIPTION
ddi_dma_free_handle() destroys the DMA handle pointed to by handle. Any further references to the DMA handle will have undefined results. Note that ddi_dma_unbind_handle(9F) must be called prior to ddi_dma_free_handle() to free any resources the system may be caching on the handle.
CONTEXT
ddi_dma_free_handle() can be called from user, kernel, or interrupt context.
SEE ALSO
ddi_dma_alloc_handle(9F), ddi_dma_unbind_handle(9F) Writing Device Drivers SunOS 5.11 26 Sep 1994 ddi_dma_free_handle(9F)
Related Man Pages
ddi_dma_unbind_handle(9f) - opensolaris
ddi_dma_unbind_handle(9f) - centos
ddi_dma_free_handle(9f) - xfree86
ddi_dma_free_handle(9f) - osx
ddi_dma_free_handle(9f) - posix
Similar Topics in the Unix Linux Community
Trying to block signal
PHP Man Pages Now Available (Over 10,000)
Change directory for core file
Identify problem with while getopts
Solaris 10 - password complexity not working