Query: ddi_dma_free
OS: opensolaris
Section: 9f
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
ddi_dma_free(9F) Kernel Functions for Drivers ddi_dma_free(9F)NAMEddi_dma_free - release system DMA resourcesSYNOPSIS#include <sys/ddi.h> #include <sys/sunddi.h> int ddi_dma_free(ddi_dma_handle_t handle);INTERFACE LEVELThis interface is obsolete. ddi_dma_free_handle(9F) should be used instead.PARAMETERShandle The handle filled in by a call to ddi_dma_setup(9F).DESCRIPTIONThe ddi_dma_free() function releases system DMA resources set up by ddi_dma_setup(9F). When a DMA transfer completes, the driver should free up system DMA resources established by a call to ddi_dma_setup(9F). This is done by a call to ddi_dma_free(). ddi_dma_free() does an implicit ddi_dma_sync(9F) for you so any further synchronization steps are not necessary.RETURN VALUESThe ddi_dma_free() function returns: DDI_SUCCESS Successfully released resources DDI_FAILURE Failed to free resourcesCONTEXTThe ddi_dma_free() function can be called from user, interrupt, or kernel context.ATTRIBUTESSee attributes(5) for a description of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Stability Level |Obsolete | +-----------------------------+-----------------------------+SEE ALSOattributes(5), ddi_dma_addr_setup(9F), ddi_dma_buf_setup(9F), ddi_dma_free_handle(9F), ddi_dma_htoc(9F), ddi_dma_sync(9F), ddi_dma_req(9S) Writing Device Drivers SunOS 5.11 16 Jan 2006 ddi_dma_free(9F)
Related Man Pages |
---|
ddi_dma_buf_setup(9f) - opensolaris |
ddi_dma_setup(9f) - minix |
ddi_dma_setup(9f) - suse |
ddi_dma_setup(9f) - v7 |
ddi_dma_setup(9f) - mojave |
Similar Topics in the Unix Linux Community |
---|
Trying to block signal |
PHP Man Pages Now Available (Over 10,000) |
Change directory for core file |
Identify problem with while getopts |
%memused is high |