opensolaris man page for ddi_dma_curwin

Query: ddi_dma_curwin

OS: opensolaris

Section: 9f

Links: opensolaris man pages   all man pages

Forums: unix linux community   forum categories

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

ddi_dma_curwin(9F)					   Kernel Functions for Drivers 					ddi_dma_curwin(9F)

NAME
ddi_dma_curwin - report current DMA window offset and size
SYNOPSIS
#include <sys/conf.h> #include <sys/ddi.h> #include <sys/sunddi.h> int ddi_dma_curwin(ddi_dma_handle_t handle, off_t *offp, uint_t *lenp);
INTERFACE LEVEL
This interface is obsolete. ddi_dma_getwin(9F) should be used instead.
PARAMETERS
handle The DMA handle filled in by a call to ddi_dma_setup(9F). offp A pointer to a value which will be filled in with the current offset from the beginning of the object that is mapped for DMA. lenp A pointer to a value which will be filled in with the size, in bytes, of the current window onto the object that is mapped for DMA.
DESCRIPTION
The ddi_dma_curwin() function reports the current DMA window offset and size. If a DMA mapping allows partial mapping, that is if the DDI_DMA_PARTIAL flag in the ddi_dma_req(9S) structure is set, its current (effective) DMA window offset and size can be obtained by a call to ddi_dma_curwin().
RETURN VALUES
The ddi_dma_curwin() function returns: DDI_SUCCESS The current length and offset can be established. DDI_FAILURE Otherwise.
CONTEXT
The ddi_dma_curwin() function can be called from user, interrupt, or kernel context.
ATTRIBUTES
See attributes(5) for a description of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Stability Level |Obsolete | +-----------------------------+-----------------------------+
SEE ALSO
attributes(5), ddi_dma_getwin(9F), ddi_dma_movwin(9F), ddi_dma_setup(9F), ddi_dma_req(9S) Writing Device Drivers SunOS 5.11 16 Jan 2006 ddi_dma_curwin(9F)
Related Man Pages
ddi_dma_curwin(9f) - centos
ddi_dma_movwin(9f) - centos
ddi_dma_curwin(9f) - php
ddi_dma_movwin(9f) - minix
ddi_dma_curwin(9f) - suse
Similar Topics in the Unix Linux Community
How to learn UNIX
solaris zones vs container..
Free Sun Blade 2k, Ultra 2, Ross Hyperstation 30, cards, memory- Baltimore, MD
Identify problem with while getopts
Shopt -s histappend