opensolaris man page for csx_parse_cistpl_jedec_a

Query: csx_parse_cistpl_jedec_a

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

csx_Parse_CISTPL_JEDEC_C(9F)				   Kernel Functions for Drivers 			      csx_Parse_CISTPL_JEDEC_C(9F)

NAME
csx_Parse_CISTPL_JEDEC_C, csx_Parse_CISTPL_JEDEC_A - parse JEDEC Identifier tuples
SYNOPSIS
#include <sys/pccard.h> int32_t csx_Parse_CISTPL_JEDEC_C(client_handle_t ch, tuple_t *tu, cistpl_jedec_t *cj); int32_t csx_Parse_CISTPL_JEDEC_A(client_handle_t ch, tuple_t *tu, cistpl_jedec_t *cj);
INTERFACE LEVEL
Solaris DDI Specific (Solaris DDI)
PARAMETERS
ch Client handle returned from csx_RegisterClient(9F). tu Pointer to a tuple_t structure (see tuple(9S)) returned by a call to csx_GetFirstTuple(9F) or csx_GetNextTuple(9F). cj Pointer to a cistpl_jedec_t structure which contains the parsed CISTPL_JEDEC_C or CISTPL_JEDEC_A tuple information upon return from these functions, respectively.
DESCRIPTION
csx_Parse_CISTPL_JEDEC_C() and csx_Parse_CISTPL_JEDEC_A() parse the JEDEC Identifier tuples, CISTPL_JEDEC_C and CISTPL_JEDEC_A, respec- tively, into a form usable by PC Card drivers. The CISTPL_JEDEC_C and CISTPL_JEDEC_A tuples are optional tuples provided for cards containing programmable devices. They describe informa- tion for Common Memory or Attribute Memory space, respectively.
STRUCTURE MEMBERS
The structure members of cistpl_jedec_t are: uint32_t nid; /* # of JEDEC identifiers present */ jedec_ident_t jid[CISTPL_JEDEC_MAX_IDENTIFIERS]; The structure members of jedec_ident_t are: uint32_t id; /* manufacturer id */ uint32_t info; /* manufacturer specific info */
RETURN VALUES
CS_SUCCESS Successful operation. CS_BAD_HANDLE Client handle is invalid. CS_UNKNOWN_TUPLE Parser does not know how to parse tuple. CS_NO_CARD No PC Card in socket. CS_NO_CIS No Card Information Structure (CIS) on PC Card. CS_UNSUPPORTED_FUNCTION No PCMCIA hardware installed.
CONTEXT
These functions may be called from user or kernel context.
SEE ALSO
csx_GetFirstTuple(9F), csx_GetTupleData(9F), csx_Parse_CISTPL_DEVICE(9F), csx_RegisterClient(9F), csx_ValidateCIS(9F), tuple(9S) PC Card 95 Standard, PCMCIA/JEIDA SunOS 5.11 20 Dec 1996 csx_Parse_CISTPL_JEDEC_C(9F)
Related Man Pages
csx_parse_cistpl_date(9f) - sunos
csx_parse_cistpl_jedec_c(9f) - sunos
csx_parse_cistpl_spcl(9f) - sunos
csx_parse_cistpl_jedec_c(9f) - opensolaris
csx_parse_cistpl_longlink_c(9f) - opensolaris
Similar Topics in the Unix Linux Community
How to learn UNIX
PHP Man Pages Now Available (Over 10,000)
What's legal and what's not?
What is good?
Shopt -s histappend