Query: pcq_get
OS: netbsd
Section: 9
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
PCQ(9) BSD Kernel Developer's Manual PCQ(9)NAMEpcq -- producer/consumer queueSYNOPSIS#include <sys/pcq.h> pcq_t * pcq_create(size_t maxlen, km_flags_t kmflags); void pcq_destroy(pcq_t *pcq); void * pcq_get(pcq_t *pcq); size_t pcq_maxitems(pcq_t *pcq); void * pcq_peek(pcq_t *pcq); bool pcq_put(pcq_t *pcq, void *item);DESCRIPTIONThe machine-independent pcq interface provides lockless producer/consumer queues. A queue (pcq_t) allows multiple writers (producers), but only a single reader (consumer). The consumer is expected to be protected by a lock that covers the structure that the pcq_t is embedded into (e.g., socket lock, ifnet hwlock). These queues operate in a first-in, first-out (FIFO) manner. The act of inserting or removing an item from a pcq_t does not modify the item in any way. pcq does not prevent an item from being inserted multiple times into a single pcq_t.FUNCTIONSpcq_create(maxlen, kmflags) Create a queue that can store at most maxlen items at one time. kmflags should be either KM_SLEEP, if pcq_create() is allowed to sleep until resources are available, or KM_NOSLEEP if it should return NULL immediately, if resources are unavailable. pcq_destroy(pcq) Free the resources held by pcq. pcq_get(pcq) Remove the next item to be consumed from the queue and return it. If the queue is empty, return NULL. The caller must prevent con- current gets from occuring. pcq_maxitems(pcq) Return the maximum number of items that the queue can store at any one time. pcq_peek(pcq) Return the next item to be consumed from the queue but do not remove it from the queue. If the queue is empty, return NULL. pcq_put(pcq, item) Place an item at the end of the queue. If there is no room in the queue for the item, return false; otherwise, return true. The item must not have the value of NULL.CODE REFERENCESThe pcq interface is implemented within the file sys/kern/subr_pcq.c.SEE ALSOatomic_ops(3), queue(9)HISTORYThe pcq interface first appeared in NetBSD 6.0.BSDJanuary 22, 2012 BSD
Related Man Pages |
---|
pcq_get(9) - netbsd |
queue(3) - opendarwin |
queue(9s) - php |
queue(3) - plan9 |
queue(9s) - redhat |
Similar Topics in the Unix Linux Community |
---|
producer consumer |
producer consumer |
producer consumer |
producer consumer semaphore |
producer consumer semaphore |