netbsd man page for kpreempt

Query: kpreempt

OS: netbsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

KPREEMPT(9)						   BSD Kernel Developer's Manual					       KPREEMPT(9)

NAME
kpreempt -- control kernel preemption
SYNOPSIS
#include <sys/systm.h> void kpreempt_disable(void); void kpreempt_enable(void); bool kpreempt_disabled(void);
DESCRIPTION
These functions are used to control kernel preemption of the calling LWP. On architectures where kernel preemption is not supported natively, these functions may still be used. It should be noted that kernel preemption is also disabled when holding the interrupt priority level above IPL_NONE, e.g. using spl(9) or spinning mutex(9) calls or holding kernel_lock (indicating that the code is not MT safe). kpreempt_disable() disables kernel preemption of the calling LWP. Note that disabling kernel preemption can prevent LWPs with higher priori- ties from running. kpreempt_enable() enables kernel preemption of the calling LWP, which was previously disabled by kpreempt_disable(). kpreempt_disable() and kpreempt_enable() can be nested. kpreempt_disabled() returns true if preemption of the calling LWP is disabled. It is only for diagnostic purpose.
SEE ALSO
intro(9), mutex(9), spl(9)
BSD
February 16, 2010 BSD
Related Man Pages
schedctl_init(3c) - opensolaris
schedctl_stop(3c) - opensolaris
schedctl_init(3c) - sunos
schedctl_stop(3c) - sunos
schedctl_lookup(3c) - sunos
Similar Topics in the Unix Linux Community
Vm versus physical linux server
RFC - Korn shell prompt
BSD Unix Toolbox: 1000+ Commands for FreeBSD, OpenBSD, and NetBSD