Query: ieee80211_ioctl
OS: netbsd
Section: 9
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
IEEE80211_IOCTL(9) BSD Kernel Developer's Manual IEEE80211_IOCTL(9)NAMEieee80211_cfgget, ieee80211_cfgset, ieee80211_ioctl -- 802.11 interface ioctl commandsSYNOPSIS#include <net80211/ieee80211_var.h> #include <net80211/ieee80211_proto.h> #include <net80211/ieee80211_ioctl.h> int ieee80211_cfgget(struct ieee80211com *ic, u_long cmd, void *data); int ieee80211_cfgset(struct ieee80211com *ic, u_long cmd, void *data); int ieee80211_ioctl(struct ieee80211com *ic, u_long cmd, void *data);DESCRIPTIONThese functions are typically invoked by drivers in response to requests for information or to change settings from the userland. The ieee80211_cfgget() and ieee80211_cfgset() functions implement a legacy interface for getting and setting 802.11 interface attributes respectively. The interface is compatible with the RIDs implemented by the wi(4) driver and used by the wiconfig(8) utility. The ieee80211_ioctl() function implements ioctls such as key management for wireless devices. Ioctls related to the Ethernet layer also pass through here, but are handed off to ether_ioctl() when no match for cmd is found.SEE ALSOwi(4), ifconfig(8), wiconfig(8), ieee80211(9)HISTORYThe ieee80211 series of functions first appeared in NetBSD 1.5, and were later ported to FreeBSD 4.6.AUTHORSThis man page was written by Bruce M. Simpson <bms@FreeBSD.org> and Darron Broad <darron@kewl.org>.BSDSeptember 12, 2006 BSD
Related Man Pages |
---|
ieee80211_mhz2ieee(9) - netbsd |
ieee80211_watchdog(9) - netbsd |
ieee80211(9) - netbsd |
ieee80211_media2rate(9) - netbsd |
ieee80211_media_init(9) - netbsd |
Similar Topics in the Unix Linux Community |
---|
Better to Use Return Code or wc -l Output? |
Adding a List of Times |
Grandpa returning to UNIX |
Grep command to show the number of results |