netbsd man page for getbinuptime

Query: getbinuptime

OS: netbsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

MICROUPTIME(9)						   BSD Kernel Developer's Manual					    MICROUPTIME(9)

NAME
binuptime, getbinuptime, microuptime, getmicrouptime, nanouptime, getnanouptime -- get the time elapsed since boot
SYNOPSIS
#include <sys/time.h> void binuptime(struct bintime *bt); void getbinuptime(struct bintime *bt); void microuptime(struct timeval *tv); void getmicrouptime(struct timeval *tv); void nanouptime(struct timespec *ts); void getnanouptime(struct timespec *tsp);
DESCRIPTION
The binuptime() and getbinuptime() functions store the time elapsed since boot as a struct bintime at the address specified by bt. The microuptime() and getmicrouptime() functions perform the same utility, but record the elapsed time as a struct timeval instead. Similarly the nanouptime() and getnanouptime() functions store the elapsed time as a struct timespec. The used structures are described in timeval(3). The binuptime(), microuptime(), and nanouptime() functions always query the timecounter to return the current time as precisely as possible. Whereas getbinuptime(), getmicrouptime(), and getnanouptime() functions are abstractions which return a less precise, but faster to obtain, time. The intent of the getbinuptime(), getmicrouptime(), and getnanouptime() functions is to enforce the user's preference for timer accuracy ver- sus execution time. They should be used where a precision of 1/HZ (e.g., 10 msec on a 100HZ machine, see hz(9)) is acceptable or where per- formance is priority.
SEE ALSO
microtime(9), timecounter(9), tvtohz(9)
AUTHORS
This manual page was written by Kelly Yancey <kbyanc@posi.net>.
BSD
June 8, 2010 BSD
Related Man Pages
nanouptime(9) - netbsd
getbinuptime(9) - debian
getmicrouptime(9) - netbsd
getnanouptime(9) - hpux
microuptime(9) - hpux
Similar Topics in the Unix Linux Community
sorting left-justified numeric values
How to install PGX32 on Sparc 10 Ultra?
RFC - Korn shell prompt
Grandpa returning to UNIX