netbsd man page for cltp

Query: cltp

OS: netbsd

Section: 4

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

CLTP(4) 						   BSD Kernel Interfaces Manual 						   CLTP(4)

NAME
cltp -- ISO Connectionless Transport Protocol
SYNOPSIS
#include <sys/socket.h> #include <netiso/iso.h> int socket(AF_ISO, SOCK_DGRAM, 0);
DESCRIPTION
CLTP is a simple, unreliable datagram protocol which is accessed via the SOCK_DGRAM abstraction for the ISO protocol family. CLTP sockets are connectionless, and are normally used with the sendto(2) and recvfrom(2) calls, though the connect(2) call may also be used to fix the destination for future packets (in which case the recv(2) or read(2) and send(2) or write(2) system calls may be used). CLTP address formats are identical to those used by TP. In particular CLTP provides a service selector in addition to the normal ISO NSAP. Note that the CLTP selector space is separate from the TP selector space (i.e. a CLTP selector may not be ``connected'' to a TP selector). Options at the CLNP network level may be used with CLTP; see clnp(4).
DIAGNOSTICS
A socket operation may fail with one of the following errors returned: [EISCONN] when trying to establish a connection on a socket which already has one, or when trying to send a datagram with the destina- tion address specified and the socket is already connected; [ENOTCONN] when trying to send a datagram, but no destination address is specified, and the socket hasn't been connected; [ENOBUFS] when the system runs out of memory for an internal data structure; [EADDRINUSE] when an attempt is made to create a socket with a selector which has already been allocated; [EADDRNOTAVAIL] when an attempt is made to create a socket with a network address for which no network interface exists.
SEE ALSO
getsockopt(2), recv(2), send(2), socket(2), clnp(4), intro(4), iso(4)
BSD
June 9, 1993 BSD
Related Man Pages
idp(4p) - bsd
imp(4p) - bsd
icmp(4) - netbsd
udp(4) - netbsd
udp(7) - osf1
Similar Topics in the Unix Linux Community
socket
How to config NSAP address???
UDP socket - can both client and server recv and send
Store file into a buffer to send it through a socket
Threading Segmentation fault