mojave man page for getminor

Query: getminor

OS: mojave

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

getminor(9F)                                               Kernel Functions for Drivers                                               getminor(9F)

NAME
getminor - get minor device number
SYNOPSIS
#include <sys/types.h> #include <sys/mkdev.h> #include <sys/ddi.h> minor_t getminor(dev_t dev);
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
PARAMETERS
dev Device number.
DESCRIPTION
getminor() extracts the minor number from a device number.
RETURN VALUES
The minor number.
CONTEXT
getminor() can be called from user or interrupt context.
EXAMPLES
See the getmajor(9F) manual page for an example of how to use getminor().
SEE ALSO
getmajor(9F), makedevice(9F) Writing Device Drivers
WARNINGS
No validity checking is performed. If dev is invalid, an invalid number is returned. SunOS 5.10 11 Apr 1991 getminor(9F)
Related Man Pages
getmajor(9f) - sunos
getmajor(9f) - mojave
getmajor(9f) - php
getmajor(9f) - centos
getmajor(9f) - linux
Similar Topics in the Unix Linux Community
Linux Device Drivers
Learn Linux File System and Device Drivers
AIX: mkdev is waiting in kernel at et_wait