Query: vop_setattr
OS: freebsd
Section: 9
Links: freebsd man pages all man pages
Forums: unix linux community forum categories
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
VOP_ATTRIB(9) BSD Kernel Developer's Manual VOP_ATTRIB(9)NAMEVOP_GETATTR, VOP_SETATTR -- get and set attributes on a file or directorySYNOPSIS#include <sys/param.h> #include <sys/vnode.h> int VOP_GETATTR(struct vnode *vp, struct vattr *vap, struct ucred *cred); int VOP_SETATTR(struct vnode *vp, struct vattr *vap, struct ucred *cred);DESCRIPTIONThese entry points manipulate various attributes of a file or directory, including file permissions, owner, group, size, access time and mod- ification time. The arguments are: vp The vnode of the file. vap The attributes of the file. cred The user credentials of the calling process. Attributes which are not being modified by VOP_SETATTR() should be set to the value VNOVAL; VATTR_NULL() may be used to clear all the values, and should generally be used to reset the contents of *vap prior to setting specific values.LOCKSVOP_GETATTR() expects the vnode to be locked on entry and will leave the vnode locked on return. The lock type can be either shared or exclusive. VOP_SETATTR() expects the vnode to be locked on entry and will leave the vnode locked on return. The lock type must be exclusive.RETURN VALUESVOP_GETATTR() returns 0 if it was able to retrieve the attribute data via *vap, otherwise an appropriate error is returned. VOP_SETATTR() returns zero if the attributes were changed successfully, otherwise an appropriate error is returned.ERRORS[EPERM] The file is immutable. [EACCES] The caller does not have permission to modify the file or directory attributes. [EROFS] The file system is read-only.SEE ALSOVFS(9), vnode(9), VOP_ACCESS(9)AUTHORSThis manual page was written by Doug Rabson.BSDAugust 29, 2008 BSD
Related Man Pages |
---|
vop_getattr(9) - debian |
vop_setattr(9) - debian |
vop_attrib(9) - freebsd |
vop_attrib(9) - php |
vop_attrib(9) - minix |
Similar Topics in the Unix Linux Community |
---|
Time for this guy to leave us? |