freebsd man page for vfs_suser

Query: vfs_suser

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

VFS_SUSER(9)						   BSD Kernel Developer's Manual					      VFS_SUSER(9)

NAME
vfs_suser -- check if credentials have superuser privileges for a mount point
SYNOPSIS
#include <sys/param.h> #include <sys/systm.h> #include <sys/mount.h> int vfs_suser(struct mount *mp, struct thread *td);
DESCRIPTION
The vfs_suser() function checks if the credentials given include superuser powers for the given mount point. It will check to see if the thread passed in has the same credentials as the user that mounted the file system. If so, it returns 0, otherwise it returns what priv_check(9) would have returned.
RETURN VALUES
The vfs_suser() function returns 0 if the user has superuser powers and EPERM otherwise. This is the reverse logic of some other implementa- tions of suser() in which a TRUE response indicates superuser powers.
SEE ALSO
chroot(2), jail(2)
HISTORY
The vfs_suser() function was introduced in FreeBSD 5.2.
AUTHORS
This manual page was written by Alfred Perlstein.
BSD
April 2, 2004 BSD
Related Man Pages
vfs_statfs(9) - debian
vfs_checkexp(9) - freebsd
vfs_statfs(9) - freebsd
vop_access(9) - opensolaris
vop_access(9) - php
Similar Topics in the Unix Linux Community
The Whole Story on #! /usr/bin/ksh
Scripts without shebang
Is UNIX an open source OS ?
UNIX Environment Setup - (Just starting!)