freebsd man page for vfs_checkexp

Query: vfs_checkexp

OS: freebsd

Section: 9

Links: freebsd man pages   all man pages

Forums: unix linux community   forum categories

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

VFS_CHECKEXP(9) 					   BSD Kernel Developer's Manual					   VFS_CHECKEXP(9)

NAME
VFS_CHECKEXP -- check if a file system is exported to a client
SYNOPSIS
#include <sys/param.h> #include <sys/mount.h> int VFS_CHECKEXP(struct mount *mp, struct sockaddr *nam, int *exflagsp, struct ucred **credanonp);
DESCRIPTION
The VFS_CHECKEXP() macro is used by the NFS server to check if a mount point is exported to a client. The arguments it expects are: mp The mount point to be checked. nam An mbuf containing the network address of the client. exflagsp Return parameter for the export flags for this client. credanonp Return parameter for the anonymous credentials for this client. The VFS_CHECKEXP() macro should be called on a file system's mount structure to determine if it is exported to a client whose address is con- tained in nam. It is generally called before VFS_FHTOVP(9) to validate that a client has access to the file system. The file system should call vfs_export_lookup(9) with the address of an appropriate netexport structure and the address of the client, nam, to verify that the client can access this file system.
RETURN VALUES
The export flags and anonymous credentials specific to the client (returned by vfs_export_lookup(9)) will be returned in *exflagsp and *credanonp.
SEE ALSO
VFS(9), VFS_FHTOVP(9), vnode(9), VOP_VPTOFH(9)
AUTHORS
This manual page was written by Alfred Perlstein.
BSD
January 4, 2010 BSD
Related Man Pages
vfs_checkexp(9) - debian
vfs_fhtovp(9) - freebsd
vfs_fhtovp(9) - linux
vfs_fhtovp(9) - hpux
vfs_fhtovp(9) - osx
Similar Topics in the Unix Linux Community
How to Call a Function with in two files
how to mount /home on NIS client machine
Make a file accept only two arguments from the command line