freebsd man page for memcchr

Query: memcchr

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

MEMCCHR(9)						   BSD Kernel Developer's Manual						MEMCCHR(9)

NAME
memcchr -- locate the complement of a byte in byte string
SYNOPSIS
#include <sys/libkern.h> void * memcchr(const void *b, int c, size_t len);
DESCRIPTION
The memcchr() function locates the first occurrence of a byte unequal to c (converted to an unsigned char) in string b.
RETURN VALUES
The memcchr() function returns a pointer to the byte located, or NULL if no such byte exists within len bytes.
SEE ALSO
memchr(3)
HISTORY
The memcchr() function first appeared in FreeBSD 10.0.
BSD
January 1, 2012 BSD
Related Man Pages
memchr(3) - freebsd
strrchr(3) - freebsd
bstring(3) - netbsd
memchr(3) - netbsd
memrchr(3) - netbsd
Similar Topics in the Unix Linux Community
FreeBSD Kernel Internals, Dr. Marshall Kirk McKusick
Is UNIX an open source OS ?
A simple UNIXtime component in Vue.js
Valid separator in time and date format
UNIX Environment Setup - (Just starting!)