freebsd man page for count_dev

Query: count_dev

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

VCOUNT(9)						   BSD Kernel Developer's Manual						 VCOUNT(9)

NAME
vcount, count_dev -- get total number of references to a device
SYNOPSIS
#include <sys/param.h> #include <sys/time.h> #include <sys/conf.h> #include <sys/vnode.h> int vcount(struct vnode *vp); int count_dev(struct cdev *dev);
DESCRIPTION
vcount() is used to get the number of references to a particular device. It allows for the fact that multiple vnodes may reference the same device. count_dev() does the same thing as vcount(), but takes a struct cdev rather than a struct vnode pointer as an argument.
RETURN VALUES
vcount() and count_dev() both return the number of references to the device.
SEE ALSO
VFS(9), vnode(9)
AUTHORS
This manual page was written by Andrew Stevenson.
BSD
January 19, 2012 BSD
Related Man Pages
vput(9) - debian
vop_link(9) - centos
vop_link(9) - minix
vop_link(9) - linux
vop_link(9) - hpux
Similar Topics in the Unix Linux Community
How Many Computers Do You Have At Home?
How to Read &amp; Compare Two Files