freebsd man page for bus_generic_detach

Query: bus_generic_detach

OS: freebsd

Section: 9

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

BUS_GENERIC_DETACH(9)					   BSD Kernel Developer's Manual				     BUS_GENERIC_DETACH(9)

NAME
bus_generic_detach -- generic implementation of DEVICE_DETACH for busses
SYNOPSIS
#include <sys/param.h> #include <sys/bus.h> int bus_generic_detach(device_t dev);
DESCRIPTION
This function provides an implementation of the DEVICE_DETACH(9) method which can be used by most bus code. It simply calls the DEVICE_DETACH(9) method of each child device attached to the bus.
RETURN VALUES
Zero is returned on success, otherwise an appropriate error is returned.
SEE ALSO
device(9), driver(9)
AUTHORS
This manual page was written by Doug Rabson.
BSD
June 16, 1998 BSD
Related Man Pages
device_attach(9) - freebsd
device_identify(9) - freebsd
device_identify(9) - linux
device_attach(9) - linux
device_detach(9) - osx
Similar Topics in the Unix Linux Community
The Whole Story on #! /usr/bin/ksh
Valid separator in time and date format
Is it safe to install x86 Solaris 10 U6 after installed-Linux-and-FreeBSD?
Controlling user input