Query: nochpoll
OS: bsd
Section: 9f
Links: bsd man pages all man pages
Forums: unix linux community forum categories
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
nochpoll(9F) Kernel Functions for Drivers nochpoll(9F) NAME
nochpoll - error return function for non-pollable devices SYNOPSIS
#include <sys/ddi.h> #include <sys/sunddi.h> int nochpoll(dev_t dev, short events, int anyyet, short *reventsp, struct pollhead **pollhdrp); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
dev Device number. events Event flags. anyyet Check current events only. reventsp Event flag pointer. pollhdrp Poll head pointer. DESCRIPTION
nochpoll() is a routine that simply returns the value ENXIO. It is intended to be used in the cb_ops(9S) structure of a device driver for devices that do not support the poll(2) system call. RETURN VALUES
nochpoll() returns ENXIO. CONTEXT
nochpoll() can be called from user or interrupt context. SEE ALSO
poll(2), chpoll(9E), cb_ops(9S) Writing Device Drivers SunOS 5.10 11 Oct 1995 nochpoll(9F)
Related Man Pages |
---|
nochpoll(9f) - sunos |
nochpoll(9f) - centos |
nochpoll(9f) - redhat |
nochpoll(9f) - bsd |
nochpoll(9f) - osf1 |
Similar Topics in the Unix Linux Community |
---|
Where can I find Linux functions corresponding to the Solaris DDI? |