datab(9S) Data Structures for Drivers datab(9S)NAME
datab, dblk - STREAMS message data structure
SYNOPSIS
#include <sys/stream.h>
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
DESCRIPTION
The datab structure describes the data of a STREAMS message. The actual data contained in a STREAMS message is stored in a data buffer
pointed to by this structure. A msgb (message block) structure includes a field that points to a datab structure.
Because a data block can have more than one message block pointing to it at one time, the db_ref member keeps track of a data block's ref-
erences, preventing it from being deallocated until all message blocks are finished with it.
STRUCTURE MEMBERS
unsigned char *db_base; /* first byte of buffer */
unsigned char *db_lim; /* last byte (+1) of buffer */
unsigned char db_ref; /* # of message pointers to this data */
unsigned char db_type; /* message type */
A datab structure is defined as type dblk_t.
SEE ALSO free_rtn(9S), msgb(9S)
Writing Device Drivers
STREAMS Programming Guide
SunOS 5.10 24 Oct 2003 datab(9S)
Check Out this Related Man Page
msgb(9S) Data Structures for Drivers msgb(9S)NAME
msgb, mblk - STREAMS message block structure
SYNOPSIS
#include <sys/stream.h>
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI)
DESCRIPTION
A STREAMS message is made up of one or more message blocks, referenced by a pointer to a msgb structure. The b_next and b_prev pointers
are used to link messages together on a QUEUE. The b_cont pointer links message blocks together when a message consists of more than one
block.
Each msgb structure also includes a pointer to a datab(9S) structure, the data block (which contains pointers to the actual data of the
message), and the type of the message.
STRUCTURE MEMBERS
struct msgb *b_next; /* next message on queue */
struct msgb *b_prev; /* previous message on queue */
struct msgb *b_cont; /* next message block */
unsigned char *b_rptr; /* 1st unread data byte of buffer */
unsigned char *b_wptr; /* 1st unwritten data byte of buffer */
struct datab *b_datap; /* pointer to data block */
unsigned char b_band; /* message priority */
unsigned short b_flag; /* used by stream head */
Valid flags are as follows:
MSGMARK Last byte of message is marked.
MSGDELIM Message is delimited.
The msgb structure is defined as type mblk_t.
SEE ALSO datab(9S)
Writing Device Drivers
STREAMS Programming Guide
SunOS 5.10 11 Apr 1991 msgb(9S)
Hi everyone,
I have a problem on sco unixware 7.1.4
a Ghost process is consuming cpu usage.
rtpm
cpu 0 ======---------
cpu 1 ===---------------------
cpu 2 ============================================================-----------
cpu 3 ... (1 Reply)
Hi,
I want to insert some lines in between the contents of a file but the file format should not be changed.
#!/usr/bin/sh -
# Link appropriate OS specific versions of vxicap and vxchk4badblks
vxlvmlink()
{
vxipath=/usr/lib/vxvm/bin
relmajor=`uname -v`
... (1 Reply)
Hi All,
In the output of TOP command in my unix system, i monitored that some process has utilization more than 100% even some process has 4000% utilisation.
Please help me understand how it is possible to show more than 100% utilization.
Please see the screenshot below:... (2 Replies)
Overview:
Introduction
What Does Success Mean?
What Does Performance Mean?
Every Picture is Worth a Thousand Words
Work Like a Physicist
Work Like You Walk - One Step at a Time
Learn to Know Your System
Choose Your Weapons!
Tools of the Trade 1 - vmstat
A Little Theory Along the Way -... (1 Reply)
Hi Everyone!
I am facing an issue in running a command line utility from the CRON.
This utility displays IPC statistics on UNIX message queues: The "queue name" and the "count" of messages in the queue.
When running this utility from prompt, it will provide an output on the screen, like the... (4 Replies)
I am connecting a USB mass storage removeable drive to Solaris 10 x86 machine.
The device is detected and i am able to perform standard read and write functions.
But i want to use a code to send IOCTL based SCSI commands to the same device to read and write the data. Which i am unable to do so.... (17 Replies)
I am getting this error:
Can't locate loadable object for module IO::Tty in @INC (@INC contains: /production/79p/perl5/lib/site_perl/5.28.0/x86_64-linux /production/79p/perl5/lib/site_perl/5.28.0 /production/79p/perl5/lib/5.28.0/x86_64-linux /production/79p/perl5/lib/5.28.0... (2 Replies)