Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

pm_trans_check(9f) [sunos man page]

pm_trans_check(9F)					   Kernel Functions for Drivers 					pm_trans_check(9F)

NAME
pm_trans_check - Device power cycle advisory check SYNOPSIS
#include <sys/sunddi.h> int pm_trans_check(struct pm_trans_data *datap, time_t *intervalp); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI) PARAMETERS
datap Pointer to a pm_trans_data structure intervalp Pointer to time difference when next power cycle will be advised DESCRIPTION
The pm_trans_check(9F) function checks if a power-cycle is currently advised based on data in the pm_trans_data structure. This function is provided to prevent damage to devices from excess power cycles; drivers for devices that are sensitive to the number of power cycles should call pm_trans_check(9F) from their power(9E) function before powering-off a device. If pm_trans_check(9F) indicates that the device should not be power cycled, the driver should not attempt to power cycle the device and should fail the call to power(9E) entry point. If pm_trans_check(9F) returns that it is not advised to power cycle the device, it attempts to calculate when the next power cycle is advised, based on the supplied parameters. In such case, intervalp returns the time difference (in seconds) from the current time to when the next power cycle is advised. If the time for the next power cycle cannot be determined, intervalp indicates 0. To avoid excessive calls to the power(9E) entry point during a period when power cycling is not advised, the driver should mark the corre- sponding device component busy for the intervalp time period (if interval is not 0). Conveniently, the driver can utilize the fact that calls to pm_busy_component(9F) are stacked. If power cycling is not advised, the driver can call pm_busy_component(9F) and issue a timeout(9F) for the intervalp time. The timeout() handler can issue the corresponding pm_idle_component(9F) call. When the format field of pm_trans_data is set to DC_SCSI_FORMAT, the caller must provide valid data in svc_date[], lifemax, and ncycles. Currently, flag must be set to 0. struct pm_scsi_cycles { int lifemax; /* lifetime max power cycles */ int ncycles; /* number of cycles so far */ char svc_date[DC_SCSI_MFR_LEN]; /* service date YYYYWW */ int flag; /* reserved for future */ }; struct pm_trans_data { int format; /* data format */ union { struct pm_scsi_cycles scsi_cycles; } un; }; RETURN VALUES
"small and bold">Power cycle is advised 0 Power cycle is not advised -1 Error due to invalid argument. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Interface Stability |Evolving | +-----------------------------+-----------------------------+ SEE ALSO
power.conf(4), attributes(5), power(9E) Writing Device Drivers Using Power Management SunOS 5.10 16 Oct 1999 pm_trans_check(9F)

Check Out this Related Man Page

power(9E)							Driver Entry Points							 power(9E)

NAME
power - power a device attached to the system SYNOPSIS
#include <sys/ddi.h> #include <sys/sunddi.h> int prefixpower(dev_info_t *dip, int component, int level); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). This entry point is required. If the driver writer does not supply this entry point, the value NULL must be used in the cb_ops(9S) structure instead. PARAMETERS
dip Pointer to the device's dev_info structure. component Component of the driver to be managed. level Desired component power level. DESCRIPTION
The power(9E) function is the device-specific Power Management entry point. This function is called when the system wants the driver to set the power level of component to level. The level argument is the driver-defined power level to which the component needs to be set. Except for power level 0, which is inter- preted by the framework to mean "powered off," the interpretation of level is entirely up to the driver. The component argument is the component of the device to be power-managed. The interpretation of component is entirely up to the driver. When a requested power transition would cause the device to lose state, the driver must save the state of the device in memory. When a requested power transition requires state to be restored, the driver must restore that state. If a requested power transition for one component requires another component to change power state before it can be completed, the driver must call pm_raise_power(9F) to get the other component changed, and the power(9E) entry point must support being re-entered. If the system requests an inappropriate power transition for the device (for example, a request to power down a device which has just become busy), then the power level should not be changed and power should return DDI_FAILURE. RETURN VALUES
The power() function returns: DDI_SUCCESS Successfully set the power to the requested level. DDI_FAILURE Failed to set the power to the requested level. CONTEXT
The power() function is called from user or kernel context only. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Interface stability |Evolving | +-----------------------------+-----------------------------+ SEE ALSO
attach(9E), detach(9E), pm_busy_component(9F), pm_idle_component(9F), pm_raise_power(9F), cb_ops(9S) Writing Device Drivers Using Power Management SunOS 5.10 12 Dec 2003 power(9E)
Man Page