Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

ldi_ident_from_stream(9f) [sunos man page]

ldi_ident_from_dev(9F)					   Kernel Functions for Drivers 				    ldi_ident_from_dev(9F)

NAME
ldi_ident_from_dev, ldi_ident_from_stream, ldi_ident_from_dip, ldi_ident_release - ldi cookie management SYNOPSIS
#include <sys/sunldi.h> int ldi_ident_from_dip(dev_info_t *dip, ldi_ident_t *lip); int ldi_ident_from_dev(dev_t dev, ldi_ident_t *lip); void ldi_ident_from_stream(struct queue *sq, ldi_ident_t *lip); void ldi_ident_release(ldi_ident_t li); PARAMETERS
li ldi identifier. lip ldi identifier pointer. dip Pointer to device info node dev Device number sq Pointer to a stream queue DESCRIPTION
The ldi_ident_from_dev() function allocates and returns an ldi identifier that is associated with the device number specified by dev. The new ldi identifier is returned via the ldi identifier pointer parameter lip. The ldi_ident_from_dip() function allocates and returns an ldi identifier that is associated with the device info node pointed to by dip. The new ldi identifier is returned via the ldi identifier pointer parameter lip. The ldi_ident_from_stream() function allocates and returns an ldi identifier that is associated with the stream pointed to by queue. The new ldi identifier is returned via the ldi identifier pointer parameter lip. The ldi_ident_release() function releases an identifier that was allocated via one of the ldi_ident_from()* functions. RETURN VALUES
The ldi_ident_from_dev(), ldi_ident_from_dip(), and ldi_ident_from_stream() functions return 0 upon success. All of these functions return EINVAL for invalid input parameters. CONTEXT
These functions can be called from user or kernel context. SunOS 5.10 3 June 2003 ldi_ident_from_dev(9F)

Check Out this Related Man Page

ldi_ident_from_dev(9F)					   Kernel Functions for Drivers 				    ldi_ident_from_dev(9F)

NAME
ldi_ident_from_dev, ldi_ident_from_stream, ldi_ident_from_dip, ldi_ident_release - ldi cookie management SYNOPSIS
#include <sys/sunldi.h> int ldi_ident_from_dip(dev_info_t *dip, ldi_ident_t *lip); int ldi_ident_from_dev(dev_t dev, ldi_ident_t *lip); void ldi_ident_from_stream(struct queue *sq, ldi_ident_t *lip); void ldi_ident_release(ldi_ident_t li); PARAMETERS
li ldi identifier. lip ldi identifier pointer. dip Pointer to device info node dev Device number sq Pointer to a stream queue DESCRIPTION
The ldi_ident_from_dev() function allocates and returns an ldi identifier that is associated with the device number specified by dev. The new ldi identifier is returned via the ldi identifier pointer parameter lip. The ldi_ident_from_dip() function allocates and returns an ldi identifier that is associated with the device info node pointed to by dip. The new ldi identifier is returned via the ldi identifier pointer parameter lip. The ldi_ident_from_stream() function allocates and returns an ldi identifier that is associated with the stream pointed to by queue. The new ldi identifier is returned via the ldi identifier pointer parameter lip. The ldi_ident_release() function releases an identifier that was allocated via one of the ldi_ident_from()* functions. RETURN VALUES
The ldi_ident_from_dev(), ldi_ident_from_dip(), and ldi_ident_from_stream() functions return 0 upon success. All of these functions return EINVAL for invalid input parameters. CONTEXT
These functions can be called from user or kernel context. SunOS 5.10 3 June 2003 ldi_ident_from_dev(9F)
Man Page