Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

kstat_install(9f) [sunos man page]

kstat_install(9F)					   Kernel Functions for Drivers 					 kstat_install(9F)

NAME
kstat_install - add a fully initialized kstat to the system SYNOPSIS
#include <sys/types.h> #include <sys/kstat.h> void kstat_install(kstat_t *ksp); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI) PARAMETERS
ksp Pointer to a fully initialized kstat(9S) structure. DESCRIPTION
kstat_install() is used in conjunction with kstat_create(9F) to allocate and initialize a kstat(9S) structure. After a successful call to kstat_create() the driver must perform any necessary initialization of the data section (such as setting the name fields in a kstat of type KSTAT_TYPE_NAMED). Virtual kstats must have the ks_data field set at this time. The provider may also set the ks_update, ks_private, and ks_lock fields if necessary. Once the kstat is completely initialized, kstat_install is used to make the kstat accessible to the outside world. RETURN VALUES
None. CONTEXT
kstat_install() can be called from user or kernel context. EXAMPLES
Example 1: Allocating and Initializing a kstat Structure The method for allocating and initializing a kstat structure is generally as follows: kstat_t *ksp; ksp = kstat_create(module, instance, name, class, type, ndata, flags); if (ksp) { /* ... provider initialization, if necessary */ kstat_install(ksp); } SEE ALSO
kstat_create(9F), kstat_delete(9F), kstat_named_init(9F), kstat(9S) Writing Device Drivers SunOS 5.10 26 May 1994 kstat_install(9F)

Check Out this Related Man Page

ks_update(9E)							Driver Entry Points						     ks_update(9E)

NAME
ks_update - dynamically update kstats SYNOPSIS
#include <sys/types.h> #include <sys/kstat.h> #include <sys/ddi.h> #include <sys/sunddi.h> int prefix_ks_update(kstat_t *ksp, int rw); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI) PARAMETERS
ksp Pointer to a kstat(9S) structure. rw Read/Write flag. Possible values are KSTAT_READ Update kstat structure statistics from the driver. KSTAT_WRITE Update driver statistics from the kstat structure. DESCRIPTION
The kstat mechanism allows for an optional ks_update() function to update kstat data. This is useful for drivers where the underlying device keeps cheap hardware statistics, but extraction is expensive. Instead of constantly keeping the kstat data section up to date, the driver can supply a ks_update() function which updates the kstat's data section on demand. To take advantage of this feature, set the ks_update field before calling kstat_install(9F). The ks_update() function must have the following structure: static int xx_kstat_update(kstat_t *ksp, int rw) { if (rw == KSTAT_WRITE) { /* update the native stats from ksp->ks_data */ /* return EACCES if you don't support this */ } else { /* update ksp->ks_data from the native stats */ } return(0); } In general, the ks_update() routine may need to refer to provider-private data; for example, it may need a pointer to the provider's raw statistics. The ks_private field is available for this purpose. Its use is entirely at the provider's discretion. No kstat locking should be done inside the ks_update() routine. The caller will already be holding the kstat's ks_lock (to ensure consis- tent data) and will prevent the kstat from being removed. RETURN VALUES
ks_update() should return 0 For success. EACCES If KSTAT_WRITE is not allowed. EIO For any other error. SEE ALSO
kstat_create(9F), kstat_install(9F), kstat(9S) Writing Device Drivers SunOS 5.11 27 May 1994 ks_update(9E)
Man Page