Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

kstat(9s) [sunos man page]

kstat(9S)						    Data Structures for Drivers 						 kstat(9S)

NAME
kstat - kernel statistics structure SYNOPSIS
#include <sys/types.h> #include <sys/kstat.h> #include <sys/ddi.h> #include <sys/sunddi.h> INTERFACE LEVEL
Solaris DDI specific (Solaris DDI) DESCRIPTION
Each kernel statistic (kstat) exported by device drivers consists of a header section and a data section. The kstat structure is the header portion of the statistic. A driver receives a pointer to a kstat structure from a successful call to kstat_create(9F). Drivers should never allocate a kstat struc- ture in any other manner. After allocation, the driver should perform any further initialization needed before calling kstat_install(9F) to actually export the kstat. STRUCTURE MEMBERS
void *ks_data; /* kstat type-specific data */ ulong_t ks_ndata; /* # of type-specific data records */ ulong_t ks_data_size; /* total size of kstat data section */ int (*ks_update)(struct kstat *, int); void *ks_private; /* arbitrary provider-private data */ void *ks_lock; /* protects this kstat's data */ The members of the kstat structure available to examine or set by a driver are as follows: ks_data Points to the data portion of the kstat. Either allocated by kstat_create(9F) for the drivers use, or by the driver if it is using virtual kstats. ks_ndata The number of data records in this kstat. Set by the ks_update(9E) routine. ks_data_size The amount of data pointed to by ks_data. Set by the ks_update(9E) routine. ks_update Pointer to a routine that dynamically updates kstat. This is useful for drivers where the underlying device keeps cheap hardware statistics, but where extraction is expensive. Instead of constantly keeping the kstat data section up to date, the driver can supply a ks_update(9E) function that updates the kstat data section on demand. To take advantage of this feature, set the ks_update field before calling kstat_install(9F). ks_private Is a private field for the driver's use. Often used in ks_update(9E). ks_lock Is a pointer to a mutex that protects this kstat. kstat data sections are optionally protected by the per-kstat ks_lock. If ks_lock is non-NULL, kstat clients (such as /dev/kstat) will acquire this lock for all of their operations on that kstat. It is up to the kstat provider to decide whether guaranteeing consistent data to kstat clients is sufficiently important to justify the locking cost. Note, however, that most statistic updates already occur under one of the provider's mutexes. If the provider sets ks_lock to point to that mutex, then kstat data locking is free. ks_lock is really of type (kmutex_t*) and is declared as (void*) in the kstat header. That way, users do not have to be exposed to all of the kernel's lock- related data structures. SEE ALSO
kstat_create(9F) Writing Device Drivers SunOS 5.10 4 Apr 1994 kstat(9S)

Check Out this Related Man Page

ks_snapshot(9E) 						Driver Entry Points						   ks_snapshot(9E)

NAME
ks_snapshot - take a snapshot of kstat data SYNOPSIS
#include <sys/types.h> #include <sys/kstat.h> #include <sys/ddi.h> #include <sys/sunddi.h> int prefix_ks_snapshot(kstat_t *ksp, void *buf, int rw); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
ksp Pointer to a kstat(9S) structure. buf Pointer to a buffer to copy the snapshot into. rw Read/Write flag. Possible values are: KSTAT_READ Copy driver statistics from the driver to the buffer. KSTAT_WRITE Copy statistics from the buffer to the driver. DESCRIPTION
The kstat mechanism allows for an optional ks_snapshot() function to copy kstat data. This is the routine that is called to marshall the kstat data to be copied to user-land. A driver can opt to use a custom snapshot routine rather than the default snapshot routine; to take advantage of this feature, set the ks_snapshot field before calling kstat_install(9F). The ks_snapshot() function must have the following structure: static int xx_kstat_snapshot(kstat_t *ksp, void *buf, int rw) { if (rw == KSTAT_WRITE) { /* set the native stats to the values in buf */ /* return EACCES if you don't support this */ } else { /* copy the kstat-specific data into buf */ } return(0); } In general, the ks_snapshot() routine might need to refer to provider-private data; for example, it might need a pointer to the provider's raw statistics. The ks_private field is available for this purpose. Its use is entirely at the provider's discretion. No kstat locking should be done inside the ks_update() routine. The caller will already be holding the kstat's ks_lock (to ensure consis- tent data) and will prevent the kstat from being removed. 1. ks_snaptime must be set (via gethrtime(9F)) to timestamp the data. 2. Data gets copied from the kstat to the buffer on KSTAT_READ, and from the buffer to the kstat on KSTAT_WRITE. RETURN VALUES
0 Success EACCES If KSTAT_WRITE is not allowed EIO For any other error CONTEXT
This function is called from user context only. EXAMPLES
Example 1 Named kstats with Long Strings (KSTAT_DATA_STRING) static int xxx_kstat_snapshot(kstat_t *ksp, void *buf, int rw) { if (rw == KSTAT_WRITE) { return (EACCES); } else { kstat_named_t *knp = buf; char *end = knp + ksp->ks_ndata; uint_t i; bcopy(ksp->ks_data, buf, sizeof (kstat_named_t) * ksp->ks_ndata); /* * Now copy the strings to the end of the buffer, and * update the pointers appropriately. */ for (i = 0; i < ksp->ks_ndata; i++, knp++) if (knp->data_type == KSTAT_DATA_STRING && KSTAT_NAMED_STR_PTR(knp) != NULL) { bcopy(KSTAT_NAMED_STR_PTR(knp), end, KSTAT_NAMED_STR_BUFLEN(knp)); KSTAT_NAMED_STR_PTR(knp) = end; end += KSTAT_NAMED_STR_BUFLEN(knp); } } return(0); } SEE ALSO
ks_update(9E), kstat_create(9F), kstat_install(9F), kstat(9S) Writing Device Drivers SunOS 5.11 4 Dec 2002 ks_snapshot(9E)
Man Page