Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

flushband(9f) [sunos man page]

flushband(9F)						   Kernel Functions for Drivers 					     flushband(9F)

NAME
flushband - flush messages for a specified priority band SYNOPSIS
#include <sys/stream.h> void flushband(queue_t *q, unsigned char pri, int flag); INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI). PARAMETERS
q Pointer to the queue. pri Priority of messages to be flushed. flag Valid flag values are: FLUSHDATA Flush only data messages (types M_DATA, M_DELAY, M_PROTO, and M_PCPROTO ). FLUSHALL Flush all messages. DESCRIPTION
flushband() flushes messages associated with the priority band specified by pri. If pri is 0, only normal and high priority messages are flushed. Otherwise, messages are flushed from the band pri according to the value of flag. CONTEXT
flushband() can be called from user or interrupt context. SEE ALSO
flushq(9F) Writing Device Drivers STREAMS Programming Guide SunOS 5.10 11 Apr 1991 flushband(9F)

Check Out this Related Man Page

flushq(9F)						   Kernel Functions for Drivers 						flushq(9F)

NAME
flushq - remove messages from a queue SYNOPSIS
#include <sys/stream.h> void flushq(queue_t *q, int flag); INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI). PARAMETERS
q Pointer to the queue to be flushed. flag Valid flag values are: FLUSHDATA Flush only data messages (types M_DATA M_DELAY M_PROTO and M_PCPROTO). FLUSHALL Flush all messages. DESCRIPTION
flushq() frees messages and their associated data structures by calling freemsg(9F). If the queue's count falls below the low water mark and the queue was blocking an upstream service procedure, the nearest upstream service procedure is enabled. CONTEXT
flushq() can be called from user or interrupt context. EXAMPLES
Example 1: Using flushq() This example depicts the canonical flushing code for STREAMS modules. The module has a write service procedure and potentially has messages on the queue. If it receives an M_FLUSH message, and if the FLUSHR bit is on in the first byte of the message (line 10), then the read queue is flushed (line 11). If the FLUSHW bit is on (line 12), then the write queue is flushed (line 13). Then the message is passed along to the next entity in the stream (line 14). See the example for qreply(9F) for the canonical flushing code for drivers. 1 /* 2 * Module write-side put procedure. 3 */ 4 xxxwput(q, mp) 5 queue_t *q; 6 mblk_t *mp; 7 { 8 switch(mp->b_datap->db_type) { 9 case M_FLUSH: 10 if (*mp->b_rptr & FLUSHR) 11 flushq(RD(q), FLUSHALL); 12 if (*mp->b_rptr & FLUSHW) 13 flushq(q, FLUSHALL); 14 putnext(q, mp); 15 break; . . . 16 } 17 } SEE ALSO
flushband(9F), freemsg(9F), putq(9F), qreply(9F) Writing Device Drivers STREAMS Programming Guide SunOS 5.10 11 Apr 1991 flushq(9F)
Man Page

13 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

Delete lines with a word and their above lines

Hi, i have a file like this: A1 kdfjdljfdkljfdlf A2 lfjdlfkjddkjf A3 ***no hit*** A4 ldjfldjfdk A5 ***no hit*** A6 jldfjdlfjdlkfjd I want to remove the lines "***no hit*** and their above line to get an output file like this: (11 Replies)
Discussion started by: the_simpsons
11 Replies

2. War Stories

The 500 Mile Email

Not my story, but interesting enough to be worth posting here IMHO. (Original is here) The following is the 500-mile email story in the form it originally appeared, in a post to sage-members on Sun, 24 Nov 2002.: From trey@sage.org Fri Nov 29 18:00:49 2002 Date: Sun, 24 Nov 2002 21:03:02... (3 Replies)
Discussion started by: Corona688
3 Replies

3. Fedora

Is UNIX an open source OS ?

Hi everyone, I know the following questions are noobish questions but I am asking them because I am confused about the basics of history behind UNIX and LINUX. Ok onto business, my questions are-: Was/Is UNIX ever an open source operating system ? If UNIX was... (21 Replies)
Discussion started by: sreyan32
21 Replies

4. Shell Programming and Scripting

How to convert number to english?

Hi gurus, I have a weird requirement. I need to convert the number to english lecture. I have 1.2 ....19 numbers I need to convert to first second third fourth, fifth, sixth... Is there any way convert it using unix command? thanks in advance. (8 Replies)
Discussion started by: ken6503
8 Replies

5. UNIX for Dummies Questions & Answers

UNIX fun stuff - echo and dc - obfuscate/garble a string sort of

Hi, Humorous UNIX Commands shows a fun way of using echo and dc to sort of obfuscate a string. % echo 'sasb3135071790101768542287578439snlbxq'|dc GET A LIFE! I am just wanting to know if there is a way to sort of use dc and echo to print out an obfuscated/garbled string instead... (3 Replies)
Discussion started by: newbie_01
3 Replies

6. Shell Programming and Scripting

Merge and Sort tabular data from different text files

I have 42 text files; each containing up to 34 lines with following structure; file1 H-01 23 H-03 5 H-05 9 H-02 14 . . file2 H-01 17 H-02 43 H-04 7 H-05 8 H-03 7 . . file3 (6 Replies)
Discussion started by: Syeda Sumayya
6 Replies

7. War Stories

Once upon an uptime.

Hi All, Having recently started a new job, a Data Center Migration in fact I have been tasked with looking at some of the older Solaris boxes when I came across this little gem. nismas# uname -a SunOS nismas 5.5.1 Generic_103640-27 sun4u sparc SUNW,Ultra-1 nismas# uptime 10:37am up 2900... (2 Replies)
Discussion started by: gull04
2 Replies

8. UNIX for Advanced & Expert Users

How do I remove or hide SunOS version/release from remote login prompt?

For any SunOS 5.XX release, it appears prior to the "login:" prompt (as if a "uname" command is run). Would anyone know where that initial display of SunOS release comes from upon a remote login and how I can stop if from displaying? Thank you (4 Replies)
Discussion started by: ssid61
4 Replies

9. Shell Programming and Scripting

Using awk to remove lines from file that match text

I am trying to remove each line in which $2 is FP or RFP. I believe the below will remove one instance but not both. Thank you :). file 12 123 FP 11 10 RFP awk awk -F'\t' ' $2 != "FP"' file desired output 12 11 (6 Replies)
Discussion started by: cmccabe
6 Replies

10. UNIX for Beginners Questions & Answers

Best performance UNIX just for HOST Virtualization?

Hi everybody, Which Unix base OS have best performance for HOST virtualization? I tested SmartOS but it needs another OS to connect remotely! Thanks in advance. (11 Replies)
Discussion started by: mbzadegan
11 Replies

11. Shell Programming and Scripting

Outputting sequences based on length with sed

I have this file: >ID1 AA >ID2 TTTTTT >ID-3 AAAAAAAAA >ID4 TTTTTTGGAGATCAGTAGCAGATGACAG-GGGGG-TGCACCCC Add I am trying to use this script to output sequences longer than 15 characters: sed -r '/^>/N;{/^.{,15}$/d}' The desire output would be this: >ID4... (8 Replies)
Discussion started by: Xterra
8 Replies

12. Shell Programming and Scripting

Sort only numbers within a string

Hi, I am having contents in a file like below, cat testfile rpool/swap rpool/swap14 rpool/swap2 rpool/swap3 I want to sort the above contents like, rpool/swap rpool/swap2 rpool/swap3 rpool/swap14 I have tried in this way, (7 Replies)
Discussion started by: Sumanthsv
7 Replies

13. UNIX for Beginners Questions & Answers

UNIX Environment Setup - (Just starting!)

Morning All So, I am starting looking into the world of UNIX for a new job (luckily not my primary function!) and I am looking to get stared. Like anything I seem to learn best by trying things out first in an environment but I have a key question: Currently I use Oracle VirtualBox, can... (8 Replies)
Discussion started by: GophusMeau
8 Replies