Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

csx_deregisterclient(9f) [sunos man page]

csx_DeregisterClient(9F)				   Kernel Functions for Drivers 				  csx_DeregisterClient(9F)

NAME
csx_DeregisterClient - remove client from Card Services list SYNOPSIS
#include <sys/pccard.h> int32_t csx_DeregisterClient(client_handle_t ch); INTERFACE LEVEL
Solaris DDI Specific (Solaris DDI) PARAMETERS
ch Client handle returned from csx_RegisterClient(9F). DESCRIPTION
This function removes a client from the list of registered clients maintained by Card Services. The Client Handle returned by csx_Register- Client(9F) is passed in the client_handle_t argument. The client must have returned all requested resources before this function is called. If any resources have not been released, CS_IN_USE is returned. RETURN VALUES
CS_SUCCESS Successful operation. CS_BAD_HANDLE Client handle is invalid. CS_IN_USE Resources not released by this client. CS_UNSUPPORTED_FUNCTION No PCMCIA hardware installed. CONTEXT
This function may be called from user or kernel context. SEE ALSO
csx_RegisterClient(9F) PC Card 95 Standard, PCMCIA/JEIDA WARNINGS
Clients should be prepared to receive callbacks until Card Services returns from this request successfully. SunOS 5.10 19 Jul 1996 csx_DeregisterClient(9F)

Check Out this Related Man Page

csx_MapLogSocket(9F)					   Kernel Functions for Drivers 				      csx_MapLogSocket(9F)

NAME
csx_MapLogSocket - return the physical socket number associated with the client handle SYNOPSIS
#include <sys/pccard.h> int32_t csx_MapLogSocket(client_handle_t ch, map_log_socket_t *ls); INTERFACE LEVEL
Solaris DDI Specific (Solaris DDI) PARAMETERS
ch Client handle returned from csx_RegisterClient(9F). ls Pointer to a map_log_socket_t structure. DESCRIPTION
This function returns the physical socket number associated with the client handle. STRUCTURE MEMBERS
The structure members of map_log_socket_t are: uint32_t LogSocket; /* logical socket number */ uint32_t PhyAdapter; /* physical adapter number */ uint32_t PhySocket; /* physical socket number */ The fields are defined as follows: LogSocket Not used by this implementation of Card Services and can be set to any arbitrary value. PhyAdapter Returns the physical adapter number, which is always 0 in the Solaris implementation of Card Services. PhySocket Returns the physical socket number associated with the client handle. The physical socket number is typically used as part of an error or message string or if the client creates minor nodes based on the physical socket number. RETURN VALUES
CS_SUCCESS Successful operation. CS_BAD_HANDLE Client handle is invalid. CS_UNSUPPORTED_FUNCTION No PCMCIA hardware installed. CONTEXT
This function may be called from user or kernel context. SEE ALSO
csx_RegisterClient(9F) PC Card 95 Standard, PCMCIA/JEIDA SunOS 5.10 19 Jul 1996 csx_MapLogSocket(9F)
Man Page

6 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

df command on Linux and Solaris

Hello all, Does anyone know how to fix this? My directory is mounted from a Soalris Server and both Solaris and Linux Client are mountting my directory. But when I use df and awk together the reset are different on the platform. under Solaris clinet I get whant I want: df -k... (1 Reply)
Discussion started by: larry
1 Replies

2. Shell Programming and Scripting

Unix Services (Solaris 9)

(2 Replies)
Discussion started by: BCarlson
2 Replies

3. Virtualization and Cloud Computing

NX Nomachine - German Keyboard does not work

Hello, I´m trying to get NX Nomachine working. On the server I use NX Free Edition for Solaris (running on Sparc Solaris 10 update 5). The Client is NX Client for Windows running on XP Professional. So far so good. Nearly everything works fine. The only problem is, that I always have the US... (1 Reply)
Discussion started by: bluemax
1 Replies

4. Shell Programming and Scripting

SED to remove a line above and lines below.

:confused:Hi All, I need help on removing lines in a text file. Sample file : When there is a match ip for IPAddress in my `cat ip.out`, proceed delete line above until string "Comp" is found. Thank you very much. ---------- Post updated at 12:56 AM ---------- Previous update was... (4 Replies)
Discussion started by: chiewming
4 Replies

5. Hardware

seeking QUIET hardware Sparc Solaris 8/Openwin

I have several applications locked to Solaris 8 (and older) and have been very happy with my Sparcs and Ultras but am getting tinnitus problems from fans and disks. Any tips on a quiet thin client (with decent graphics, not video or gaming level but 24bit and multi monitor would be useful) that... (0 Replies)
Discussion started by: batchman
0 Replies

6. Shell Programming and Scripting

Mail related

I have maintaining 16 client PCs.I want to get a mail from client PCs whenever any one of the services are not working.Services like postgres ,sms , jts and synch etc.,The Client PCs are remotely placed.I want to develop this through shell script ,But I don't have an idea to develop this... (2 Replies)
Discussion started by: kannansoft1985
2 Replies