Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

copyin(9f) [sunos man page]

copyin(9F)						   Kernel Functions for Drivers 						copyin(9F)

NAME
copyin - copy data from a user program to a driver buffer SYNOPSIS
#include <sys/types.h> #include <sys/ddi.h> int copyin(const void *userbuf, void *driverbuf, size_t cn); INTERFACE LEVEL
This interface is obsolete. ddi_copyin(9F) should be used instead. PARAMETERS
userbuf User program source address from which data is transferred. driverbuf Driver destination address to which data is transferred. cn Number of bytes transferred. DESCRIPTION
copyin() copies data from a user program source address to a driver buffer. The driver developer must ensure that adequate space is allo- cated for the destination address. Addresses that are word-aligned are moved most efficiently. However, the driver developer is not obligated to ensure alignment. This function automatically finds the most efficient move according to address alignment. RETURN VALUES
Under normal conditions, a 0 is returned indicating a successful copy. Otherwise, a -1 is returned if one of the following occurs: o Paging fault; the driver tried to access a page of memory for which it did not have read or write access. o Invalid user address, such as a user area or stack area. o Invalid address that would have resulted in data being copied into the user block. o Hardware fault; a hardware error prevented access to the specified user memory. For example, an uncorrectable parity or ECC error occurred. If a -1 is returned to the caller, driver entry point routines should return EFAULT. CONTEXT
copyin() can be called from user context only. EXAMPLES
Example 1: An ioctl() Routine A driver ioctl(9E) routine (line 10) can be used to get or set device attributes or registers. In the XX_GETREGS condition (line 17), the driver copies the current device register values to a user data area (line 18). If the specified argument contains an invalid address, an error code is returned. 1 struct device { /* layout of physical device registers */ 2 int control; /* physical device control word */ 3 int status; /* physical device status word */ 4 short recv_char; /* receive character from device */ 5 short xmit_char; /* transmit character to device */ 6 }; 7 8 extern struct device xx_addr[]; /* phys. device regs. location */ 9 . . . 10 xx_ioctl(dev_t dev, int cmd, int arg, int mode, 11 cred_t *cred_p, int *rval_p) 12 ... 13 { 14 register struct device *rp = &xx_addr[getminor(dev) >> 4]; 15 switch (cmd) { 16 17 case XX_GETREGS: /* copy device regs. to user program */ 18 if (copyin(arg, rp, sizeof(struct device))) 19 return(EFAULT); 20 break; 21 ... 22 } 23 ... 24 } ATTRIBUTES
See attributes(5) for a description of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Stability Level |Obsolete | +-----------------------------+-----------------------------+ SEE ALSO
attributes(5), ioctl(9E), bcopy(9F), copyout(9F), ddi_copyin(9F), ddi_copyout(9F), uiomove(9F). Writing Device Drivers NOTES
Driver writers who intend to support layered ioctls in their ioctl(9E) routines should use ddi_copyin(9F) instead. Driver defined locks should not be held across calls to this function. copyin() should not be used from a streams driver. See M_COPYIN and M_COPYOUT in STREAMS Programming Guide. SunOS 5.10 27 Sep 2002 copyin(9F)

Check Out this Related Man Page

ddi_copyout(9F) 					   Kernel Functions for Drivers 					   ddi_copyout(9F)

NAME
ddi_copyout - copy data from a driver SYNOPSIS
#include <sys/types.h> #include <sys/ddi.h> #include <sys/sunddi.h> int ddi_copyout(const void *driverbuf, void *buf, size_t cn, int flags); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
driverbuf Source address in the driver from which the data is transferred. buf Destination address to which the data is transferred. cn Number of bytes to copy. flags Set of flag bits that provide address space information about buf. DESCRIPTION
This routine is designed for use in driver ioctl(9E) routines for drivers that support layered ioctls. ddi_copyout() copies data from a driver buffer to a destination address, buf. The flags argument determines the address space information about buf. If the FKIOCTL flag is set, this indicates that buf is a kernel address, and ddi_copyout() behaves like bcopy(9F). Otherwise, buf is interpreted as a user buffer address, and ddi_copyout() behaves like copyout(9F). Addresses that are word-aligned are moved most efficiently. However, the driver developer is not obliged to ensure alignment. This func- tion automatically finds the most efficient move algorithm according to address alignment. RETURN VALUES
Under normal conditions, 0 is returned to indicate a successful copy. Otherwise, -1 is returned if one of the following occurs: o Paging fault; the driver tried to access a page of memory for which it did not have read or write access. o Invalid user address, such as a user area or stack area. o Invalid address that would have resulted in data being copied into the user block. o Hardware fault; a hardware error prevented access to the specified user memory. For example, an uncorrectable parity or ECC error occurred. If -1 is returned to the caller, driver entry point routines should return EFAULT. CONTEXT
ddi_copyout() can be called from user or kernel context only. EXAMPLES
Example 1: ddi_copyout() example A driver ioctl(9E) routine (line 12) can be used to get or set device attributes or registers. In the XX_GETREGS condition (line 25), the driver copies the current device register values to another data area. If the specified argument contains an invalid address, an error code is returned. 1 struct device { /* layout of physical device registers */ 2 int control; /* physical device control word */ 3 int status; /* physical device status word */ 4 short recv_char; /* receive character from device */ 5 short xmit_char; /* transmit character to device */ 6 }; 7 struct device_state { 8 volatile struct device *regsp; /* pointer to device registers */ 9 kmutex_t reg_mutex; /* protect device registers */ . . . 10 }; 11 static void *statep; /* for soft state routines */ 12 xxioctl(dev_t dev, int cmd, int arg, int mode, 13 cred_t *cred_p, int *rval_p) 14 { 15 struct device_state *sp; 16 volatile struct device *rp; 17 struct device reg_buf; /* temporary buffer for registers */ 18 int instance; 19 instance = getminor(dev); 20 sp = ddi_get_soft_state(statep, instance); 21 if (sp == NULL) 22 return (ENXIO); 23 rp = sp->regsp; . . . 24 switch (cmd) { 25 case XX_GETREGS: /* copy registers to arg */ 26 mutex_enter(&sp->reg_mutex); 27 /* 28 * Copy data from device registers to 29 * temporary device register buffer 30 * e.g. reg_buf.control = rp->control; 31 */ 32 mutex_exit(&sp->reg_mutex); 33 if (ddi_copyout(&reg_buf, arg, 34 sizeof (struct device), mode) != 0) { 35 return (EFAULT); 36 } 37 break; 38 } 39 } SEE ALSO
ioctl(9E), bcopy(9F), copyin(9F), copyout(9F), ddi_copyin(9F), uiomove(9F) Writing Device Drivers NOTES
The value of the flags argument to ddi_copyout() should be passed through directly from the mode argument of ioctl() untranslated. Driver defined locks should not be held across calls to this function. ddi_copyout() should not be used from a streams driver. See M_COPYIN and M_COPYOUT in STREAMS Programming Guide. SunOS 5.10 19 Apr 2000 ddi_copyout(9F)
Man Page