Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

assert(9f) [sunos man page]

ASSERT(9F)						   Kernel Functions for Drivers 						ASSERT(9F)

NAME
ASSERT, assert - expression verification SYNOPSIS
#include <sys/debug.h> void ASSERT(EX); INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI). PARAMETERS
EX boolean expression. DESCRIPTION
ASSERT() is a macro which checks to see if the expression EX is true. If it is not, then ASSERT() causes an error message to be logged to the console and the system to panic. ASSERT() works only if the preprocessor symbol DEBUG is defined. CONTEXT
ASSERT() can be used from user or interrupt context. SEE ALSO
Writing Device Drivers SunOS 5.10 11 Apr 1991 ASSERT(9F)

Check Out this Related Man Page

ASSERT(3)						     Linux Programmer's Manual							 ASSERT(3)

NAME
assert - abort the program if assertion is false SYNOPSIS
#include <assert.h> void assert(scalar expression); DESCRIPTION
If the macro NDEBUG was defined at the moment <assert.h> was last included, the macro assert() generates no code, and hence does nothing at all. Otherwise, the macro assert() prints an error message to standard output and terminates the program by calling abort() if expression is false (i.e., compares equal to zero). The purpose of this macro is to help the programmer find bugs in his program. The message "assertion failed in file foo.c, function do_bar(), line 1287" is of no help at all to a user. RETURN VALUE
No value is returned. CONFORMING TO
ISO9899 (ANSI C). In the 1990 standard, expression is required to be of type int and undefined behavior results if it is not, but in the 1999 standard it may have any scalar type. BUGS
assert() is implemented as a macro; if the expression tested has side-effects, program behaviour will be different depending on whether NDEBUG is defined. This may create Heisenbugs which go away when debugging is turned on. SEE ALSO
exit(3), abort(3), assert_perror(3) C99 2002-08-25 ASSERT(3)
Man Page

3 More Discussions You Might Find Interesting

1. UNIX for Advanced & Expert Users

SFTP error Assertion failed

I get this error when I try to FTP from an HP Alpha Server to a UNIX box. FATAL: BUILD13$:SSHFC_TRANSFER.C;1:1835 SshFCTransfer (function name unavailable) Assertion failed: tdata ->current_dest_file->attributes->flags & 0x00000004 the sftp /put fails just before it does the actual transfer.... (2 Replies)
Discussion started by: NoelSacay
2 Replies

2. Programming

Fork thread, Assertion failed. X11.

Hi all. I wrote a program with the Motif Widget Toolkit. It has a button and a scrollbar. When the user hits the button the callback creates a new fork() thread. The new thread sleeps for a while and then changes the position of the scrollbar. It does this in an endless loop. I need the... (2 Replies)
Discussion started by: mghis
2 Replies

3. Programming

Can't debug: assert error with gdb (no problem without)

I'm sorry if the title is really criptic, but I don't know how to phrase my problem. I know I can't really ask for a solution, and I normally wouldn't but this is really escaping my abilities. Antefacts. I developed a program using the zeromq messaging library. I got to a point where the... (11 Replies)
Discussion started by: erupter
11 Replies