sunos man page for module_info

Query: module_info

OS: sunos

Section: 9s

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

module_info(9S) 					    Data Structures for Drivers 					   module_info(9S)

NAME
module_info - STREAMS driver identification and limit value structure
SYNOPSIS
#include <sys/stream.h>
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
DESCRIPTION
When a module or driver is declared, several identification and limit values can be set. These values are stored in the module_info struc- ture. The module_info structure is intended to be read-only. However, the flow control limits (mi_hiwat and mi_lowat) and the packet size limits (mi_minpsz and mi_maxpsz) are copied to the QUEUE structure, where they can be modified. For a driver, mi_idname must match the name of the driver binary file. For a module, mi_idname must match the fname field of the fmodsw structure. See fmodsw(9S) for details.
STRUCTURE MEMBERS
ushort_t mi_idnum; /* module ID number */ char *mi_idname; /* module name */ ssize_t mi_minpsz; /* minimum packet size */ ssize_t mi_maxpsz; /* maximum packet size */ size_t mi_hiwat; /* high water mark */ size_t mi_lowat; /* low water mark */ The constant FMNAMESZ, limiting the length of a module's name, is set to eight in this release.
SEE ALSO
fmodsw(9S), queue(9S) STREAMS Programming Guide SunOS 5.10 26 Nov 2002 module_info(9S)
Related Man Pages
module_info(9s) - sunos
module_info(9s) - opensolaris
fmodsw(9s) - opensolaris
queue(9s) - sunos
otherq(9f) - minix
Similar Topics in the Unix Linux Community
grep -E drives me crazy
Nagios 3.2.2 on RHEL 5
Httpd not starting
Mix LDAP and LOCAL user on AIX