sunos man page for qsize

Query: qsize

OS: sunos

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

qsize(9F)						   Kernel Functions for Drivers 						 qsize(9F)

NAME
qsize - find the number of messages on a queue
SYNOPSIS
#include <sys/stream.h> int qsize(queue_t *q);
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
PARAMETERS
q Queue to be evaluated.
DESCRIPTION
qsize() evaluates the queue q and returns the number of messages it contains.
RETURN VALUES
If there are no message on the queue, qsize() returns 0. Otherwise, it returns the integer representing the number of messages on the queue.
CONTEXT
qsize() can be called from user or interrupt context.
SEE ALSO
Writing Device Drivers STREAMS Programming Guide SunOS 5.10 11 Apr 1991 qsize(9F)
Related Man Pages
canput(9f) - opensolaris
canput(9f) - centos
canput(9f) - php
canput(9f) - mojave
canput(9f) - hpux
Similar Topics in the Unix Linux Community
Thread parameter in ANSI C makes a segmentation fault
Parsing text file
Wait process holding CPU