Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

proc_signal(9f) [sunos man page]

proc_signal(9F) 					   Kernel Functions for Drivers 					   proc_signal(9F)

NAME
proc_signal, proc_ref, proc_unref - send a signal to a process SYNOPSIS
#include <sys/ddi.h> #include <sys/sunddi.h> #include <sys/signal.h> void *proc_ref(void); voidproc_unref(void *pref); int proc_signal(void *pref, int sig); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
pref A handle for the process to be signalled. sig Signal number to be sent to the process. DESCRIPTION
This set of routines allows a driver to send a signal to a process. The routine proc_ref() is used to retrieve an unambiguous reference to the process for signalling purposes. The return value can be used as a unique handle on the process, even if the process dies. Because system resources are committed to a process reference, proc_unref() should be used to remove it as soon as it is no longer needed.proc_sig- nal() is used to send signal sig to the referenced process. The following set of signals may be sent to a process from a driver: SIGHUP The device has been disconnected. SIGINT The interrupt character has been received. SIGQUIT The quit character has been received. SIGPOLL A pollable event has occurred. SIGKILL Kill the process (cannot be caught or ignored). SIGWINCH Window size change. SIGURG Urgent data are available. See signal.h(3HEAD) for more details on the meaning of these signals. If the process has exited at the time the signal was sent, proc_signal() returns an error code; the caller should remove the reference on the process by calling proc_unref(). The driver writer must ensure that for each call made to proc_ref(), there is exactly one corresponding call to proc_unref(). RETURN VALUES
proc_ref() returns the following: pref An opaque handle used to refer to the current process. proc_signal() returns the following: 0 The process existed before the signal was sent. -1 The process no longer exists; no signal was sent. CONTEXT
proc_unref() and proc_signal() can be called from user or interrupt context. proc_ref() should only be called from user context. SEE ALSO
signal.h(3HEAD), putnextctl1(9F) Writing Device Drivers SunOS 5.10 7 Feb 1994 proc_signal(9F)

Check Out this Related Man Page

KILL(2) 							System Calls Manual							   KILL(2)

NAME
kill - send signal to a process SYNOPSIS
#include <sys/types.h> #include <signal.h> int kill(pid_t pid, int sig) DESCRIPTION
Kill sends the signal sig to a process, specified by the process number pid. Sig may be one of the signals specified in sigaction(2), or it may be 0, in which case error checking is performed but no signal is actually sent. This can be used to check the validity of pid. The sending and receiving processes must have the same effective user ID, otherwise this call is restricted to the super-user. If the process number is 0, the signal is sent to all processes in the sender's process group. If the process number is -1 and the user is the super-user, the signal is broadcast universally except to init and the process sending the signal. If the process number is -1 and the user is not the super-user, the signal is broadcast universally to all processes with the same uid as the user except the process sending the signal. No error is returned if any process could be signaled. If the process number is negative but not -1, the signal is sent to all processes whose process group ID is equal to the absolute value of the process number. Processes may send signals to themselves. RETURN VALUE
Upon successful completion, a value of 0 is returned. Otherwise, a value of -1 is returned and errno is set to indicate the error. ERRORS
Kill will fail and no signal will be sent if any of the following occur: [EINVAL] Sig is not a valid signal number. [ESRCH] No process can be found corresponding to that specified by pid. [ESRCH] The process id was given as 0 but the sending process does not have a process group. [EPERM] The sending process is not the super-user and its effective user id does not match the effective user-id of the receiving process. When signaling a process group, this error was returned if any members of the group could not be signaled. SEE ALSO
getpid(2), getpgrp(2), sigaction(2), raise(3). 4th Berkeley Distribution May 14, 1986 KILL(2)
Man Page