Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

pci_save_config_regs(9f) [sunos man page]

pci_save_config_regs(9F)				   Kernel Functions for Drivers 				  pci_save_config_regs(9F)

NAME
pci_save_config_regs, pci_restore_config_regs - save and restore the PCI configuration registers SYNOPSIS
#include <sys/ddi.h> #include <sys/sunddi.h> int pci_save_config_regs(dev_info_t *dip); int pci_restore_config_regs(dev_info_t *dip); INTERFACE LEVEL
Solaris DDI-specific (Solaris DDI). ARGUMENTS
dip Pointer to the device's dev_info structure. DESCRIPTION
pci_save_config_regs() saves the current configuration registers on persistent system memory. pci_restore_config_regs() restores configura- tion registers previously saved by pci_save_config_regs(). pci_save_config_regs() should be called by the driver's power() entry point before powering a device off (to PCI state D3). Likewise, pci_restore_config_regs() should be called after powering a device on (from PCI state D3), but before accessing the device. See power(9E). RETURN VALUES
pci_save_config_regs() and pci_restore_config_regs() return: DDI_SUCCESS Operation completed successfully. DDI_FAILURE Operation failed to complete successfully. CONTEXT
Both these functions can be called from user or kernel context. EXAMPLES
Example 1: Invoking the save and restore functions static int xx_power(dev_info_t *dip, int component, int level) { struct xx *xx; int rval = DDI_SUCCESS; xx = ddi_get_soft_state(xx_softstate, ddi_get_instance(dip)); if (xx == NULL) { return (DDI_FAILURE); } mutex_enter(&xx->x_mutex); switch (level) { case PM_LEVEL_D0: XX_POWER_ON(xx); if (pci_restore_config_regs(dip) == DDI_FAILURE) { /* * appropriate error path handling here */ ... rval = DDI_FAILURE; } break; case PM_LEVEL_D3: if (pci_save_config_regs(dip) == DDI_FAILURE) { /* * appropriate error path handling here */ ... rval = DDI_FAILURE; } else { XX_POWER_OFF(xx); } break; default: rval = DDI_FAILURE; break; } mutex_exit(&xx->x_mutex); return (rval); } ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Interface Stability |Evolving | +-----------------------------+-----------------------------+ SEE ALSO
attributes(5), power(9E) Writing Device Drivers PCI Bus Power Management Interface Specification Version 1.1 PCI Bus Specification Revision 2.1 SunOS 5.10 02 June 2000 pci_save_config_regs(9F)

Check Out this Related Man Page

power(9E)							Driver Entry Points							 power(9E)

NAME
power - power a device attached to the system SYNOPSIS
#include <sys/ddi.h> #include <sys/sunddi.h> int prefixpower(dev_info_t *dip, int component, int level); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). This entry point is required. If the driver writer does not supply this entry point, the value NULL must be used in the cb_ops(9S) structure instead. PARAMETERS
dip Pointer to the device's dev_info structure. component Component of the driver to be managed. level Desired component power level. DESCRIPTION
The power(9E) function is the device-specific Power Management entry point. This function is called when the system wants the driver to set the power level of component to level. The level argument is the driver-defined power level to which the component needs to be set. Except for power level 0, which is inter- preted by the framework to mean "powered off," the interpretation of level is entirely up to the driver. The component argument is the component of the device to be power-managed. The interpretation of component is entirely up to the driver. When a requested power transition would cause the device to lose state, the driver must save the state of the device in memory. When a requested power transition requires state to be restored, the driver must restore that state. If a requested power transition for one component requires another component to change power state before it can be completed, the driver must call pm_raise_power(9F) to get the other component changed, and the power(9E) entry point must support being re-entered. If the system requests an inappropriate power transition for the device (for example, a request to power down a device which has just become busy), then the power level should not be changed and power should return DDI_FAILURE. RETURN VALUES
The power() function returns: DDI_SUCCESS Successfully set the power to the requested level. DDI_FAILURE Failed to set the power to the requested level. CONTEXT
The power() function is called from user or kernel context only. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Interface stability |Evolving | +-----------------------------+-----------------------------+ SEE ALSO
attach(9E), detach(9E), pm_busy_component(9F), pm_idle_component(9F), pm_raise_power(9F), cb_ops(9S) Writing Device Drivers Using Power Management SunOS 5.10 12 Dec 2003 power(9E)
Man Page