sunos man page for ldi_strategy

Query: ldi_strategy

OS: sunos

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

ldi_strategy(9F)					   Kernel Functions for Drivers 					  ldi_strategy(9F)

NAME
ldi_strategy - Device strategy request
SYNOPSIS
#include <sys/sunldi.h> int ldi_strategy(ldi_handle_t lh, struct buf *bp);
PARAMETERS
lh Layered handle. bp Pointer to the buf(9S) structure.
DESCRIPTION
The ldi_strategy() function passes a strategy request to the device entry point for the device specified by the layered handle. This opera- tion is supported for block devices.
RETURN VALUES
The ldi_strategy() function returns 0 if the strategy request has been passed on to the target device. Other possible return values are: EINVAL Invalid input parameters. ENOTSUP Operation is not supported for this device. Once the request has been passed on to the target devices strategy entry point, any further errors will be reported by bioerror(9F) and biodone(9F). See the strategy(9E) entry point for more information.
CONTEXT
This function may be called from user or kernel context. SunOS 5.10 3 June 2003 ldi_strategy(9F)
Related Man Pages
strategy(9e) - opensolaris
ldi_strategy(9f) - sunos
ldi_write(9f) - sunos
ldi_awrite(9f) - opensolaris
ldi_write(9f) - opensolaris
Similar Topics in the Unix Linux Community
The Law Industry Will Need A Bailout
Kernel Programming: Finding the number of I/O requests
Issue Filtering Tail
Http://www.skinscam.com/lipovyn-garcinia-cambogia-uk/