Query: strategy
OS: sunos
Section: 9e
Links: sunos man pages all man pages
Forums: unix linux community forum categories
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
strategy(9E) Driver Entry Points strategy(9E)NAMEstrategy - perform block I/OSYNOPSIS#include <sys/types.h> #include <sys/buf.h> #include <sys/ddi.h> #include <sys/sunddi.h> int prefixstrategy(struct buf *bp);INTERFACE LEVELArchitecture independent level 1 (DDI/DKI). This entry point is required for block devices.PARAMETERSbp Pointer to the buf(9S) structure.DESCRIPTIONThe strategy() routine is called indirectly (through cb_ops(9S)) by the kernel to read and write blocks of data on the block device. strat- egy() may also be called directly or indirectly to support the raw character interface of a block device (read(9E), write(9E) and ioctl(9E)). The strategy() routine's responsibility is to set up and initiate the transfer. In general, strategy() should not block. It can, however, perform a kmem_cache_alloc(9F) with both the KM_PUSHPAGE and KM_SLEEP flags set, which might block, without causing deadlock in low memory situations.RETURN VALUESThe strategy() function must return 0. On an error condition, it should call bioerror(9f) to set b_flags to the proper error code, and call biodone(9f). Note that a partial transfer is not considered to be an error.SEE ALSOioctl(9E), read(9E), write(9E), biodone(9F), bioerror(9F), buf(9S), cb_ops(9S), kmem_cache_alloc(9F) Writing Device Drivers SunOS 5.10 6 Nov 2003 strategy(9E)
Related Man Pages |
---|
minphys(9f) - opensolaris |
biodone(9f) - redhat |
biodone(9f) - centos |
biodone(9f) - minix |
biodone(9f) - linux |
Similar Topics in the Unix Linux Community |
---|
Entry Points Routine |
Locking around kmem_cache_destroy |
The Law Industry Will Need A Bailout |
Issue Filtering Tail |
Http://www.skinscam.com/lipovyn-garcinia-cambogia-uk/ |