sunos man page for kstat_delete

Query: kstat_delete

OS: sunos

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

kstat_delete(9F)					   Kernel Functions for Drivers 					  kstat_delete(9F)

NAME
kstat_delete - remove a kstat from the system
SYNOPSIS
#include <sys/types.h> #include <sys/kstat.h> void kstat_delete(kstat_t *ksp);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI)
PARAMETERS
ksp Pointer to a currently installed kstat(9S) structure.
DESCRIPTION
kstat_delete() removes ksp from the kstat chain and frees all associated system resources.
RETURN VALUES
None.
CONTEXT
kstat_delete() can be called from any context.
SEE ALSO
kstat_create(9F), kstat_install(9F), kstat_named_init(9F), kstat(9S) Writing Device Drivers
NOTES
When calling kstat_delete(), the driver must not be holding that kstat's ks_lock. Otherwise, it may deadlock with a kstat reader. SunOS 5.10 4 Apr 1994 kstat_delete(9F)
Related Man Pages
kstat_create(9f) - opensolaris
ks_update(9e) - opensolaris
ks_snapshot(9e) - sunos
kstat(9s) - sunos
ks_snapshot(9e) - opensolaris
Similar Topics in the Unix Linux Community
Delete lines with a word and their above lines
Once upon an uptime.
Best performance UNIX just for HOST Virtualization?
Outputting sequences based on length with sed