Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

csx_resetfunction(9f) [sunos man page]

csx_ResetFunction(9F)					   Kernel Functions for Drivers 				     csx_ResetFunction(9F)

NAME
csx_ResetFunction - reset a function on a PC card SYNOPSIS
#include <sys/pccard.h> int32_t csx_ResetFunction(client_handle_t ch, reset_function_t *rf); INTERFACE LEVEL
Solaris DDI Specific (Solaris DDI) PARAMETERS
ch Client handle returned from csx_RegisterClient(9F). rf Pointer to a reset_function_t structure. DESCRIPTION
csx_ResetFunction() requests that the specified function on the PC card initiate a reset operation. STRUCTURE MEMBERS
The structure members of reset_function_t are: uint32_t Socket; /* socket number */ uint32_t Attributes; /* reset attributes */ The fields are defined as follows: Socket Not used in Solaris, but for portability with other Card Services implementations, it should be set to the logical socket number. Attributes Must be 0. RETURN VALUES
CS_SUCCESS Card Services has noted the reset request. CS_IN_USE This Card Services implementation does not permit configured cards to be reset. CS_BAD_HANDLE Client handle is invalid. CS_NO_CARD No PC card in socket. CS_BAD_SOCKET Specified socket or function number is invalid. CS_UNSUPPORTED_FUNCTION No PCMCIA hardware installed. CONTEXT
This function may be called from user or kernel context. SEE ALSO
csx_event_handler(9E), csx_RegisterClient(9F) PC Card 95 Standard, PCMCIA/JEIDA NOTES
csx_ResetFunction() has not been implemented in this release and always returns CS_IN_USE. SunOS 5.10 19 Jul 1996 csx_ResetFunction(9F)

Check Out this Related Man Page

csx_ReleaseConfiguration(9F)				   Kernel Functions for Drivers 			      csx_ReleaseConfiguration(9F)

NAME
csx_ReleaseConfiguration - release PC Card and socket configuration SYNOPSIS
#include <sys/pccard.h> int32_t csx_ReleaseConfiguration(client_handle_t ch, release_config_t *rc); INTERFACE LEVEL
Solaris DDI Specific (Solaris DDI) PARAMETERS
ch Client handle returned from csx_RegisterClient(9F). rc Pointer to a release_config_t structure. DESCRIPTION
This function returns a PC Card and socket to a simple memory only interface and sets the card to configuration zero by writing a 0 to the PC card's COR (Configuration Option Register). Card Services may remove power from the socket if no clients have indicated their usage of the socket by an active csx_RequestConfigura- tion(9F) or csx_RequestWindow(9F). Card Services is prohibited from resetting the PC Card and is not required to cycle power through zero(0) volts. After calling csx_ReleaseConfiguration() any resources requested via the request functions csx_RequestIO(9F), csx_RequestIRQ(9F), or csx_RequestWindow(9F) that are no longer needed should be returned to Card Services via the corresponding csx_ReleaseIO(9F), csx_Relea- seIRQ(9F), or csx_ReleaseWindow(9F) functions. csx_ReleaseConfiguration() must be called to release the current card and socket configura- tion before releasing any resources requested by the driver via the request functions named above. STRUCTURE MEMBERS
The structure members of release_config_t are: uint32_t Socket; /* socket number */ The Socket field is not used in Solaris, but for portability with other Card Services implementations, it should be set to the logical socket number. RETURN VALUES
CS_SUCCESS Successful operation. CS_BAD_HANDLE Client handle is invalid or csx_RequestConfiguration(9F) not done. CS_BAD_SOCKET Error getting or setting socket hardware parameters. CS_NO_CARD No PC card in socket. CS_UNSUPPORTED_FUNCTION No PCMCIA hardware installed. CONTEXT
This function may be called from user or kernel context. SEE ALSO
csx_RegisterClient(9F), csx_RequestConfiguration(9F), csx_RequestIO(9F), csx_RequestIRQ(9F), csx_RequestWindow(9F) PC Card 95 Standard, PCMCIA/JEIDA SunOS 5.10 19 Jul 1996 csx_ReleaseConfiguration(9F)
Man Page