Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

csx_getnextclient(9f) [sunos man page]

csx_GetFirstClient(9F)					   Kernel Functions for Drivers 				    csx_GetFirstClient(9F)

NAME
csx_GetFirstClient, csx_GetNextClient - return first or next client SYNOPSIS
#include <sys/pccard.h> int32_t csx_GetFirstClient(get_firstnext_client_t *fnc); int32_t csx_GetNextClient(get_firstnext_client_t *fnc); INTERFACE LEVEL
Solaris DDI Specific (Solaris DDI) PARAMETERS
fnc Pointer to a get_firstnext_client_t structure. DESCRIPTION
The functions csx_GetFirstClient() and csx_GetNextClient() return information about the first or subsequent PC cards, respectively, that are installed in the system. STRUCTURE MEMBERS
The structure members of get_firstnext_client_t are: uint32_t Socket; /* socket number */ uint32_t Attributes; /* attributes */ client_handle_t client_handle; /* client handle */ uint32_t num_clients; /* number of clients */ The fields are defined as follows: Socket If the CS_GET_FIRSTNEXT_CLIENT_SOCKET_ONLY attribute is set, return information only on the PC card installed in this socket. Attributes This field indicates the type of client. The field is bit-mapped; the following bits are defined: CS_GET_FIRSTNEXT_CLIENT_ALL_CLIENTS Return information on all clients. CS_GET_FIRSTNEXT_CLIENT_SOCKET_ONLY Return client information for the specified socket only. client_handle The client handle of the PC card driver is returned in this field. num_clients The number of clients is returned in this field. RETURN VALUES
CS_SUCCESS Successful operation. CS_BAD_HANDLE Client handle is invalid. CS_BAD_SOCKET Socket number is invalid. CS_NO_CARD No PC Card in socket. CS_NO_MORE_ITEMS PC Card driver does not handle the CS_EVENT_CLIENT_INFO event. CS_UNSUPPORTED_FUNCTION No PCMCIA hardware installed. CONTEXT
This function may be called from user or kernel context. SEE ALSO
csx_event_handler(9E) PC Card 95 Standard, PCMCIA/JEIDA SunOS 5.10 16 May 1997 csx_GetFirstClient(9F)

Check Out this Related Man Page

csx_SetEventMask(9F)					   Kernel Functions for Drivers 				      csx_SetEventMask(9F)

NAME
csx_SetEventMask, csx_GetEventMask - set or return the client event mask for the client SYNOPSIS
#include <sys/pccard.h> int32_t csx_SetEventMask(client_handle_t ch, sockevent_t *se); int32_t csx_GetEventMask(client_handle_t ch, sockevent_t *se); INTERFACE LEVEL
Solaris DDI Specific (Solaris DDI) PARAMETERS
ch Client handle returned from csx_RegisterClient(9F). se Pointer to a sockevent_t structure DESCRIPTION
The function csx_SetEventMask() sets the client or global event mask for the client. The function csx_GetEventMask() returns the client or global event mask for the client. csx_RequestSocketMask(9F) must be called before calling csx_SetEventMask() for the client event mask for this socket. STRUCTURE MEMBERS
The structure members of sockevent_t are: uint32_t uint32_t /* attribute flags for call */ uint32_t EventMask; /* event mask to set or return */ uint32_t Socket; /* socket number if necessary */ The fields are defined as follows: Attributes This is a bit-mapped field that identifies the type of event mask to be returned. The field is defined as follows: CONF_EVENT_MASK_GLOBAL Client's global event mask. If set, the client's global event mask is returned. CONF_EVENT_MASK_CLIENT Client's local event mask. If set, the client's local event mask is returned. EventMask This field is bit-mapped. Card Services performs event notification based on this field. See csx_event_handler(9E) for valid event def- initions and for additional information about handling events. Socket Not used in Solaris, but for portability with other Card Services implementations, it should be set to the logical socket number. RETURN VALUES
CS_SUCCESS Successful operation. CS_BAD_HANDLE Client handle is invalid. CS_BAD_SOCKET csx_RequestSocketMask(9F) not called for CONF_EVENT_MASK_CLIENT. CS_UNSUPPORTED_FUNCTION No PCMCIA hardware installed. CONTEXT
These functions may be called from user or kernel context. SEE ALSO
csx_event_handler(9E), csx_RegisterClient(9F), csx_ReleaseSocketMask(9F), csx_RequestSocketMask(9F) PC Card 95 Standard, PCMCIA/JEIDA SunOS 5.10 19 Jul 1996 csx_SetEventMask(9F)
Man Page