Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

pckt(7m) [sunos man page]

pckt(7M)							  STREAMS Modules							  pckt(7M)

NAME
pckt - STREAMS Packet Mode module SYNOPSIS
int ioctl( fd, I_PUSH, "pckt"); DESCRIPTION
pckt is a STREAMS module that may be used with a pseudo terminal to packetize certain messages. The pckt module should be pushed (see I_PUSH on streamio(7I)) onto the master side of a pseudo terminal. Packetizing is performed by prefixing a message with an M_PROTO message. The original message type is stored in the 1 byte data portion of the M_PROTO message. On the read-side, only the M_PROTO, M_PCPROTO, M_STOP, M_START, M_STOPI, M_STARTI, M_IOCTL, M_DATA, M_FLUSH, and M_READ messages are packetized. All other message types are passed upstream unmodified. Since all unread state information is held in the master's stream head read queue, flushing of this queue is disabled. On the write-side, all messages are sent down unmodified. With this module in place, all reads from the master side of the pseudo terminal should be performed with the getmsg(2) or getpmsg() func- tion. The control part of the message contains the message type. The data part contains the actual data associated with that message type. The onus is on the application to separate the data into its component parts. SEE ALSO
getmsg(2), ioctl(2), ldterm(7M), ptem(7M), streamio(7I), termio(7I) STREAMS Programming Guide SunOS 5.10 3 Jul 1990 pckt(7M)

Check Out this Related Man Page

pckt(7) 						 Miscellaneous Information Manual						   pckt(7)

NAME
pckt - STREAMS module for constructing message packets on a pty DESCRIPTION
The pckt module is a STREAMS module that can be used with a pseudoterminal to transfer messages in packet mode. The packet mode feature of pty devices allows the user process on the master side of the device to be informed of state changes. For packet mode to be enabled in the pty device, the user process must push the pckt module onto the master side of the pty with a call to the STREAMS I_PUSH ioctl() function. When the user process writes data, the pckt module passes the message on to the next module or driver unchanged. When the user process reads data or when the pckt module receives certain STREAMS message types, it constructs a packet out of the message for forwarding upstream. To construct a message packet, the module creates an M_PROTO message. This M_PROTO message contains the original message type in the first data block and the original message in as many data blocks as needed. The user process can then retrieve the M_PROTO message with a call to the getmsg() function. The STREAMS message types that the pckt module places in packets, are the following: M_DATA M_IOCTL M_PROTO M_PCPROTO M_FLUSH M_START M_STOP M_STARTI M_STOPI M_READ All other messages are passed unchanged upstream. If the message is an M_FLUSH message, the pckt module looks at the flag and takes the following actions: If the flag is FLUSHW, the module changes it to FLUSHR before creating the M_PROTO message, and passes the message upstream. The module also sends an M_FLUSH message with the FLUSHW flag set. If the flag is FLUSHR, the module changes it to FLUSHW before creating the M_PROTO message, and passes the message upstream. If the flag is FLUSHRW, the module changes it to FLUSHW before creating the M_PROTO message, and passes the message upstream. The module also sends an M_FLUSH message with the FLUSHW flag set. RELATED INFORMATION
Functions: getmsg(2), ioctl(2). Interfaces: ldterm(7), ptem(7), streamio(7). delim off pckt(7)
Man Page