jconvu(7M) STREAMS Modules jconvu(7M)NAME
jconvu - code conversion STREAMS module (UTF-8/Japanese EUC)
SYNOPSIS
#include <sys/types.h>
#include <sys/stropt.h>
#include <sys/conf.h>
ioctl(fd, I_PUSH, "jconvu");
DESCRIPTION
jconvu is a STREAMS module that is available to be pushed onto a stream. Usually, this module has to be pushed onto a stream between a raw
device such as ptem(7M) and terminal line discipline module such as ldterm(7M).
jconvu has to be pushed when you set UTF--8 terminal. It converts up stream for UTF--8 into Japanese EUC and passes high module. It also
converts down stream for Japanese EUC into UTF--8 and passes low module.
IOCTLS
jconvu processes the following ioctls:
EUC_OXLON Start performing code conversion between UTF--8 and Japanese EUC for I/O stream.
EUC_OXLOFF Stop performing code conversion between UTF--8 and Japanese EUC for I/O stream.
SEE ALSO jtty(1), setterm(1), stty(1), streamio(7I), jconv7(7M), jconv8(7M), jconvrs(7M), jconvru(7M), jconvs(7M), ldterm(7M), ptem(7M)NOTES
When you use jconvu with jconvrs(7M) or jconvru(7M) at once and `raw' is specified by stty(1), code convert function automatically become
off without specification by EUC_OXLON / EUC_OXLOFF.
SunOS 5.10 13 Aug 1998 jconvu(7M)
Check Out this Related Man Page
Intro_jfp(7) Device and Network Interfaces Intro_jfp(7)NAME
Intro_jfp, intro_jfp - introduction to JFP special files
DESCRIPTION
This section describes various device and network interfaces available on the system. The types of interfaces described include character
and block devices, STREAMS modules, network protocols, file systems, and ioctl requests for driver subsystems and classes.
This section contains the following major collections:(7I) This section describes ioctl requests which apply to a class of drivers or subsystems. Ioctl requests relevant to only a specific
device are described on the man page for that device. The page for the device in question should still be examined for exceptions
to the ioctls listed in section 7I.(7M) This section describes STREAMS modules. Note that STREAMS drivers are discussed in section 7D. streamio(7I) contains a list of
ioctl requests used to manipulate STREAMS modules and interface with the STREAMS framework. Ioctl requests specific to a STREAMS
module will be discussed on the man page for that module.
SEE ALSO add_drv(1M), rem_drv(1M), intro(2), ioctl(2), socket(3SOCKET), driver.conf(4), intro(7), arp(7P), icmp(7P), inet(7P), ip(7P), mtio(7I),
st(7D), streamio(7I), tcp(7P), udp(7P)
STREAMS Programming Guide
Writing Device Drivers
LIST
Name Description
Intro_jfp(7) introduction to JFP special files
jaio(7I) interface to Japanese I/O modules
jconv7(7M) code conversion STREAMS module (7-bit JIS/Japanese EUC)
jconv8(7M) code conversion STREAMS module (8-bit JIS/Japanese EUC)
jconvrs(7M) code conversion STREAMS module (Japanese EUC/PC kanji)
jconvru(7M) code conversion STREAMS module (Japanese EUC/UTF--8)
jconvs(7M) code conversion STREAMS module (PC kanji/Japanese EUC)
jconvu(7M) code conversion STREAMS module (UTF-8/Japanese EUC)
SunOS 5.10 7 Dec 1999 Intro_jfp(7)
Hi all,
At present a file from AS400 system is being FTPed to an AIX system.
Now, a similar file needs to be sent from our Unix box (Solaris)
Is there any tool available which does the conversion in Unix from UTF-8 to EBCDIC?
Any suggestions/ pointers are really appreciated.
Thanks,... (4 Replies)
I have googled for weeks now and all I am getting is the same results from frank4dd's notes on setting up perl script to produce alerts in Japanese. On the contrary I wish to ensure all my alerts come in English as primary language. What I am getting from Japanese-language-Windows-machine added... (1 Reply)
Sometimes we recieve some excel files containing French/Japanese characters over the mail, and these files are manually transferred to the server by using SFTP (security is not a huge concern here). The data is changed to text format before transferring it using Notepad.
Problem is: When saving... (4 Replies)
I'm in the process of being forward-thinking and finally converting my site's db to UTF-8. I've already done the UTF-8 conversion (on a copy for testing) and now I want to go through and convert html entities to their actual characters.
I ran an entity decode on a mysqldump file but realized... (10 Replies)