sunos man page for jconv8

Query: jconv8

OS: sunos

Section: 7m

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

jconv8(7M)							  STREAMS Modules							jconv8(7M)

NAME
jconv8 - code conversion STREAMS module (8-bit JIS/Japanese EUC)
SYNOPSIS
#include <sys/types.h> #include <sys/stropt.h> #include <sys/conf.h> ioctl(fd, I_PUSH, "jconv8");
DESCRIPTION
jconv8 is a STREAMS module that is available to be pushed onto a stream. Usually, this module has to be pushed onto a stream between a raw device such as ptem(7M) and terminal line discipline module such as ldterm(7M). jconv8 has to be pushed when you set 8-bit JIS terminal and control Japanese EUC data. It converts up stream for 8-bit JIS code into Japa- nese EUC and passes high module. It also converts down stream for Japanese EUC into 8-bit JIS code and passes low module.
IOCTLS
jconv8 processes the following ioctls. JA_SKIOC and JA_GKIOC are specified pointer to the next structure as argument: struct kioc { char ki; char ko; }; JA_SKIOC Change the 3rd character of JIS kanji and ASCII indication escape sequence. JA_GKIOC Return the 3rd character of current JIS kanji and ASCII indication escape sequence. EUC_OXLON Start performing code conversion between 8-bit JIS and Japanese EUC for I/O stream. EUC_OXLOFF Stop performing code conversion between 8-bit JIS and Japanese EUC for I/O stream.
SEE ALSO
jtty(1), setterm(1), stty(1), streamio(7I), jconv7(7M), jconvrs(7M), jconvru(7M), jconvs(7M), jconvu(7M), ldterm(7M), ptem(7M)
NOTES
When you use jconv8 with jconvrs(7M) or jconvru(7M) at once and `raw' is specified by stty(1), code convert function automatically become off without specification by EUC_OXLON / EUC_OXLOFF. By default, character set indication escape sequences as follows. The end character may be changed by JA_SKIOC. o ASCII indication: ESC 2/8 4/10 o Character indication: ESC 2/4 4/2 o Convert with JIS X 0201 Kana: LS1/LS0 jconv8 does not support Kanji code for Information Interchange (secondary kanji set) provided by JIS X 0212-1990. When jconv8 is in use, csh(1) does not work properly for filename additional function. SunOS 5.10 13 Aug 1998 jconv8(7M)
Related Man Pages
jiskanji7(5) - osf1
ibmjtoeuc(1) - sunos
euctojis(1) - sunos
sjtoeuc(1) - sunos
intro_jfp(7) - sunos
Similar Topics in the Unix Linux Community
how to change every 3rd character
J-Ben 1.1.3 (Default branch)
J-Ben 1.2.0 (Default branch)
J-Ben 1.2.1 (Default branch)
J-Ben 1.2.2 (Default branch)