Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

syseventd(1m) [sunos man page]

syseventd(1M)						  System Administration Commands					     syseventd(1M)

NAME
syseventd - kernel system event notification daemon SYNOPSIS
/usr/lib/sysevent/syseventd [-d debug_level] [-r rootdir] DESCRIPTION
syseventd is a user-level daemon that accepts delivery of system event buffers from the kernel. Once an event buffer has been delivered to syseventd, it, in turn, attempts to propagate the event to all interested end event subscribers. Event subscribers take the form of a syseventd loadable module (SLM). syseventd passes the event buffer to each of its subscribers and in return expects a notification as to the successful or unsuccessful delivery attempt. Upon successful delivery of the event buffer to all interested event subscribers, syseventd frees the event buffer from the kernel event queue. OPTIONS
The following options are supported: -d debug_level Enable debug mode. Messages are printed to the invoking user's terminal. -r rootdir Cause syseventd to use an alternate root path when creating its door and lock files. Modules continue to be loaded from the standard module directories. EXIT STATUS
The following exit values are returned: 0 Successful completion. non-zero An error occurred. FILES
/etc/sysevent/syseventd_daemon.lock daemon lock file /etc/sysevent/sysevent_door kernel to syseventd door file /usr/lib/sysevent/modules SLM directory repository /usr/platform/`uname --i`/lib/sysevent/modules SLM directory repository /usr/platform/`uname --m`/lib/sysevent/modules SLM directory repository ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Availability |SUNWcsu | +-----------------------------+-----------------------------+ SEE ALSO
svcs(1), svcadm(1M), syseventconfd(1M), attributes(5), smf(5) NOTES
The syseventd service is managed by the service management facility, smf(5), under the service identifier: svc:/system/sysevent:default Administrative actions on this service, such as enabling, disabling, or requesting restart, can be performed using svcadm(1M). The ser- vice's status can be queried using the svcs(1) command. SunOS 5.10 6 Aug 2004 syseventd(1M)

Check Out this Related Man Page

sysevent_post_event(3SYSEVENT)				  System Event Library Functions			    sysevent_post_event(3SYSEVENT)

NAME
sysevent_post_event - post system event for applications SYNOPSIS
cc [ flag... ] file... -lsysevent -lnvpair [ library... ] #include <libsysevent.h> #include <libnvpair.h> int sysevent_post_event(char *class, char *subclass, char *vendor, char *publisher, nvlist_t *attr_list, sysevent_id_t *eid); PARAMETERS
attr_list pointer to an nvlist_t, listing the name-value attributes associated with the event, or NULL if there are no such attributes for this event class pointer to a string defining the event class eid pointer to a system unique identifier publisher pointer to a string defining the event's publisher nam subclass pointer to a string defining the event subclass vendor pointer to a string defining the vendor DESCRIPTION
The sysevent_post_event() function causes a system event of the specified class, subclass, vendor, and publisher to be generated on behalf of the caller and queued for delivery to the sysevent daemon syseventd(1M). The vendor should be the company stock symbol (or similarly enduring identifier) of the event posting application. The publisher should be the name of the application generating the event. For example, all events posted by Sun applications begin with the company's stock symbol, "SUNW". The publisher is usually the name of the application generating the system event. A system event generated by devfsadm(1M) has a publisher string of devfsadm. The publisher information is used by sysevent consumers to filter unwanted event publishers. Upon successful queuing of the system event, a unique identifier is assigned to eid. RETURN VALUES
The sysevent_post_event() function returns 0 if the system event has been queued successfully for delivery. Otherwise it returns -1 and sets errno to indicate the error. ERRORS
The sysevent_post_event() function will fail if: ENOMEM Insufficient resources to queue the system event. EIO The syseventd daemon is not responding and events cannot be queued or delivered at this time. EINVAL Invalid argument. EPERM Permission denied. EFAULT A copy error occurred. EXAMPLES
Example 1 Post a system event event with no attributes. The following example posts a system event event with no attributes. if (sysevent_post_event(EC_PRIV, "ESC_MYSUBCLASS", "SUNW", argv[0], NULL), &eid == -1) { fprintf(stderr, "error logging system event "); } Example 2 Post a system event with two name-value pair attributes. The following example posts a system event event with two name-value pair attributes, an integer value and a string. nvlist_t *attr_list; uint32_t uint32_val = 0XFFFFFFFF; char *string_val = "string value data"; if (nvlist_alloc(&attr_list, 0, 0) == 0) { err = nvlist_add_uint32(attr_list, "uint32 data", uint32_val); if (err == 0) err = nvlist_add_string(attr_list, "str data", string_val); if (err == 0) err = sysevent_post_event(EC_PRIV, "ESC_MYSUBCLASS", "SUNW", argv[0], attr_list, &eid); if (err != 0) fprintf(stderr, "error logging system event "); nvlist_free(attr_list); } ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Interface Stability |Evolving | +-----------------------------+-----------------------------+ |MT-Level |MT-Safe | +-----------------------------+-----------------------------+ SEE ALSO
devfsadm(1M), syseventd(1M), nvlist_add_boolean(3NVPAIR), nvlist_alloc(3NVPAIR), attributes(5) SunOS 5.11 26 May 2004 sysevent_post_event(3SYSEVENT)
Man Page