re-preinstall(1M) System Administration Commands re-preinstall(1M)
re-preinstall - installs the JumpStart software on a system
cdrom-mnt-pt/Solaris_XX/Tools/Boot/usr/sbin/install.d/re-preinstall [-m Solaris_boot_dir] [-k platform_name] target-slice
re-preinstall installs the JumpStart software (preinstall boot image) on a system, so you can power-on the system and have it automatically
install the Solaris software (perform a JumpStart installation on the system). When you turn on a re-preinstalled system, the system looks
for the JumpStart software on the system's default boot disk. All new SPARC systems have the JumpStart software already preinstalled. The
XX in Solaris_XX is the version number of the Solaris release being used.
You can use the re-preinstall command in several ways. The most common way is to run re-preinstall on a system to install the JumpStart
software on its own default boot disk. This is useful if you want to restore a system to its original factory conditions. (See the first
procedure described in EXAMPLES.)
You can also run re-preinstall on a system to install JumpStart software on any attached disk (non-boot disk). After you install the Jump-
Start software on a disk, you can move the disk to a different system and perform a JumpStart installation on the different system. (See
the second procedure described in EXAMPLES.)
re-preinstall creates a standard file system on the specified target-slice (usually slice 0), and re-preinstall makes sure there is enough
space on the target-slice for the JumpStart software. If sufficient space is not available, re-preinstall fails with the following message:
re-preinstall: target-slice too small xx Megabytes required
You can use the format(1M) command to create sufficient space on the target-slice for the JumpStart software.
The following options are supported:
-k platform_name Platform name of the system that will use the disk with the JumpStart software. The default is the platform name of
the system running re-preinstall. (Use the uname(1) command (-i option) to determine a system's platform name.)
-m Solaris_boot_dir Absolute path to the Solaris_XX/Tools/Boot subdirectory of a mounted Solaris CD or a Solaris CD copied to disk that
re-preinstall uses to install the JumpStart software. The default is root (/), which is where the Solaris CD is
mounted in single-user mode.
The following operands are supported:
target-slice Device name of the disk slice where the JumpStart software will be installed (usually slice 0), for example, c0t3d0s0.
Example 1: Installing the JumpStart Software on a System's Own Default Boot Disk
The following procedure installs the JumpStart software on a system's own default boot disk:
1. From the ok prompt, boot the system from the Solaris media CD or DVD in single-user mode:
ok boot cdrom -s
2. The following command installs the Jumpstart software on the System default boot disk, c0t0d0s0 on a Solaris 9 system:
example# /usr/sbin/install.d/re-preinstall c0t0d0s1
3. Reboot the slice:
example# reboot disk:b
Example 2: Installing the JumpStart Software on a System's Attached (non-boot) Disk
The following procedure installs the JumpStart software on a system's attached (non-boot) disk:
1. Mount the Solaris CD or DVD if vold(1M) is not running or CD or DVD is not mounted.
2. Use the format(1M) command to determine the target-slice where JumpStart will be installed.
3. Use the uname(1) command (-i option) to determine the platform name of the system that will use the re-preinstalled disk
4. Run re-preinstall with the -m Solaris_boot_dir option if the Solaris CD or DVD is not mounted on /cdrom.
The following command installs the JumpStart software on the system's attached disk for a system with a Sun4u kernel architecture, and
it uses the Solaris CD or DVD mounted with vold(1M) on a Solaris 9 system:
example# /cdrom/cdrom/s1/usr/bin/install.d/re-preinstall -m
/cdrom/cdrom/s1 -k sun4u c0t2d0s0
The following exit values are returned:
0 Successful completion.
1 An error has occurred.
See attributes(5) for descriptions of the following attributes:
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
|Availability |SUNWcdrom (Solaris CD, |
| |SPARC Platform Edition) |
uname(1), eeprom(1M), format(1M), mount(1M), vold(1M), attributes(5)
Solaris 10 Installation Guide: Basic Installations
SunOS 5.10 9 Apr 2002 re-preinstall(1M)