Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

fetch(9) [osx man page]

FETCH(9)						   BSD Kernel Developer's Manual						  FETCH(9)

NAME
fetch, fubyte, fuibyte, fuiword, fulong, fuulong, fuword -- fetch data from user-space SYNOPSIS
#include <sys/types.h> #include <sys/time.h> #include <sys/systm.h> #include <sys/resourcevar.h> int fubyte(const user_addr_t addr); int fuibyte(const user_addr_t addr); int fuiword(user_addr_t addr); int64_t fulong(user_addr_t addr); uint64_t fuulong(user_addr_t addr); int fuword(user_addr_t addr); DESCRIPTION
The fetch functions are designed to copy small amounts of data from user-space. The fetch routines provide the following functionality: fubyte() Fetches a byte of data from the user-space address addr. fuibyte() Fetches a byte of data from the user-space address addr. This function is safe to call during an interrupt context. fuiword() Fetches a word of data from the user-space address addr. This function is safe to call during an interrupt context. fulong() Fetches a long word of data from the user-space address addr. fuulong() Fetches a unsigned long word of data from the user-space address addr. fuword() Fetches a word of data from the user-space address addr. RETURN VALUES
The fetch functions return the data fetched or -1 on failure. SEE ALSO
copy(9), store(9) BSD
December 16, 2004 BSD

Check Out this Related Man Page

FETCH(9)						   BSD Kernel Developer's Manual						  FETCH(9)

NAME
fetch, fubyte, fuibyte, fuiword, fulong, fuulong, fuword -- fetch data from user-space SYNOPSIS
#include <sys/types.h> #include <sys/time.h> #include <sys/systm.h> #include <sys/resourcevar.h> int fubyte(const user_addr_t addr); int fuibyte(const user_addr_t addr); int fuiword(user_addr_t addr); int64_t fulong(user_addr_t addr); uint64_t fuulong(user_addr_t addr); int fuword(user_addr_t addr); DESCRIPTION
The fetch functions are designed to copy small amounts of data from user-space. The fetch routines provide the following functionality: fubyte() Fetches a byte of data from the user-space address addr. fuibyte() Fetches a byte of data from the user-space address addr. This function is safe to call during an interrupt context. fuiword() Fetches a word of data from the user-space address addr. This function is safe to call during an interrupt context. fulong() Fetches a long word of data from the user-space address addr. fuulong() Fetches a unsigned long word of data from the user-space address addr. fuword() Fetches a word of data from the user-space address addr. RETURN VALUES
The fetch functions return the data fetched or -1 on failure. SEE ALSO
copy(9), store(9) BSD
December 16, 2004 BSD
Man Page

4 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Replace long space to become one space?

Hi, i have the log attached. Actually i want the long space just become 1 space left like this : Rgds, (12 Replies)
Discussion started by: justbow
12 Replies

2. Shell Programming and Scripting

awk fetch numbers after the word

Hi, I would want to fetch all the numbers after a word the number of characters could very. how can I do that? below is the example of the data and the expected output sample data 03 xxxx occurs 1090 times. 04 aslkja occurs 10 times. I would want to fetch 10 & 1090 separately. (13 Replies)
Discussion started by: ahmedwaseem2000
13 Replies

3. Shell Programming and Scripting

How to combine lines?

Hi, I have a file like this: "sdfc@abc.com","arovls","some addr ", "more stuff" "ssss@email.com","arovls","some addr", "sss" "edx@email.com","arovls","some addr", "sssdfvv" "ssss@a55.com","arovls","some addr", "lsdsdgf" "ssss@0234.com","aro vls","123 Main", "lSdfv" I want to... (4 Replies)
Discussion started by: erniel
4 Replies

4. Shell Programming and Scripting

How to fetch data between two timestamps in a file using KSH

Hi, I got a requirement to fetch data between two time stamps in a big log file and grep for a word in that particular time interval of data. Here is my log looks like: 2012/04/08-14:35:56 Abcdefg 2012/04/08-14:35:56 Hijklmnophhoishfw 2012/04/08-14:35:56... (1 Reply)
Discussion started by: siri_886
1 Replies