taskgated-helper(8) BSD System Manager's Manual taskgated-helper(8)NAME
taskgated-helper -- taskgated helper process
SYNOPSIS
taskgated-helper
DESCRIPTION
The taskgated-helper utility is used by taskgated for various functions.
NOTE
The taskgated-helper utility should not be invoked directly. It is intended only for use by taskgated.
SEE ALSO profiles(1), taskgated(8)BSD May 04, 2011 BSD
Check Out this Related Man Page
taskgated(8) BSD System Manager's Manual taskgated(8)NAME
taskgated -- task_for_pid access control daemon
SYNOPSIS
taskgated [-ps] [-t timeout] [-i pid]
DESCRIPTION
taskgated is a system daemon that implements a policy for the task_for_pid system service. When the kernel is asked for the task port of a
process, and preliminary access control checks pass, it invokes this daemon (via launchd) to make the decision.
OPTIONS -p Accepts the old (Tiger) convention that a process with a primary effective group of procmod or procview is allowed to get task
ports. Without this option, this legacy mode is not supported.
-s Allow signed applications marked as "safe" to have free access to task ports, without having to pass an authorization check. Note
that such callers must be marked both allowed and safe.
-t timeout
The daemon will quit after that many seconds of inactivity. It will be relaunched by launchd as needed. A timeout of zero can be
specified to make the daemon quit after servicing each request, but a small positive timeout is better for performance.
-i pid Inject the service port of taskgated into the process with the given pid, rather than relying on launchd to install it system-wide.
This is for testing only, and requires the launchd configuration for taskgated to be removed.
AUTHORIZATION RIGHTS
system.privilege.taskport Authorization right used to check access of allowed (but not safe) callers.
INFO KEYS
SecTaskAccess A value of "allowed" is required for any program that wants access to task ports. A value of "safe" bypasses authorization
checks if so configured. Code must be signed by any system-trusted signing authority.
FILES
/etc/authorization to configure the authorization used.
/System/Library/LaunchDaemons/com.apple.taskgated
startup configuration file for taskgated
SEE ALSO security(1), launchd(8)HISTORY
taskgated was first introduced in Mac OS 10.5 (Leopard).
Certain software updates of Mac OS 10.4 (Tiger) introduced the convention requiring membership in the procmod or procview groups to control
task port access. Before that, any process could obtain the task port of any other process with the same user-id.
Darwin May 31, 2019 Darwin
Manufacturer Links
General Information
Home Page: IBM United States
Documentation/Information: IBM System p - UNIX servers: Support and services
pSeries and AIX Information Center
Developerworks AIX Wiki: AIX Wiki
AIX for System Administrators
In-depth information from IBM:
IBM... (0 Replies)
Not sure if anyone is interested but I am just getting into UNIX like shell scripting...
I have great interest in pseudo-animations in text mode and accessing HW like /dev/dsp for example...
...
Have fun, I do... ;o)
# !/bin/sh
#
# Bargraph_Generator.sh
#
# A DEMO 6 bit coloured... (0 Replies)
For a starter I know the braces are NOT in the code...
Consider these code snippets:-
#!/bin/bash --posix
x=0
somefunction()
if
then
echo "I am here."
fi
# somefunction
#!/bin/bash --posix
x=0
somefunction()
if (2 Replies)
For those interested in installing dash shell on OSX Lion to help test POSIX compliancy of shell scripts, it is quite easy. I did it like this:
If you don't have gcc on your system:
0. Download and install the Command Line Tools for Xcode package from Sign In - Apple *
1. Download the dash... (2 Replies)
Hearing Aid...
Hi folks yet another bizarre piece of code that is Apple OSX 10.12.x to at least 10.14.1 specific.
It requires only a default OSX install, and the internal microphone along with an external headphone assembly.
Pre-amble, 14-02-2019:
For over 3 weeks now I have been suffering a... (3 Replies)
What is the point of this? Whenever I close my shell it appends to the history file without adding this. I have never seen it overwrite my history file.
# When the shell exits, append to the history file instead of overwriting it
shopt -s histappend (3 Replies)
Greetings,
I'm trying to delete a file with a weird name from within Terminal on a Mac.
It's a very old file (1992) with null characters in the name: ââWord FinderÂŽ Plusâ˘.
Here are some examples of what I've tried:
12FX009:5 dpontius$ ls
ââWord FinderÂŽ Plusâ˘
12FX009:5 dpontius$ rm... (29 Replies)
I have to print the number of stars that increases on each line from the minimum number until it reaches the maximum number, and then decreases until it goes back to the minimum number. After printing out the lines of stars, it should also print the total number of stars printed.
I have tried... (13 Replies)
Hi all...
Well guys and gals, I jumped in at the deep end and found things that PERL cannot do by default.
Many tricky terminal escape codes are not catered for so I had to create workarounds.
One thing I searched for was this:
Passing perl variable to shell command
AND, @Neo this was... (15 Replies)
Well, guys I saw a question about GOTO for Python.
So this gave me the inspiration to attempt a GOTO function for 'dash', (bash and ksh too).
Machine: MBP OSX 10.14.3, default bash terminal, calling '#!/usr/local/bin/dash'...
This is purely a fun project to see if it is possible in PURE... (3 Replies)
I am sharing a code snippet.
for (( i=0; i<=$(( $count -1 )); i++ ))
do
first=${barr2}
search=${barr1}
echo $first
echo "loop begins"
for (( j=0; j<=5000; j++ ))
do
if } == $search ]]; then
echo $j
break;
fi
done
second=${harr2}
echo $second (2 Replies)
Hi All,
I'm having a python script: test.py in /path/to/script/test.py
I'm using a properties file: test_properties.py (it is having values as dictionary{}) which is in same DIR as the script.
Sample Properties file:
params = {
'target_db' : 'a1_db'
'src_db' : ... (15 Replies)