SleepServicesD(8) BSD System Manager's Manual SleepServicesD(8)NAME
SleepServicesD -- Sleep Services daemon.
SYNOPSIS DESCRIPTION
Schedules dark wakes for the purpose of receiving push notifications, and caps dark wake time based on battery drain.
FILES
/System/Library/CoreServices/SleepServicesD the daemon
/System/Library/LaunchDaemons/com.apple.sleepservicesd.plist launchd configuration plist
Darwin August 31, 2011 Darwin
Check Out this Related Man Page
xgridctl(8) BSD System Manager's Manual xgridctl(8)NAME
xgridctl -- Xgrid Daemon Control Interface
SYNOPSIS
xgridctl [target] action
OPTIONS
The optional target is one of the following:
controller perform the action for the xgricontrollerd daemon
agent perform the action for the xgridagentd daemon
The action is one of the following:
status print status for the chosen daemon, or print status for all daemons if no target is specified
start enable and start the chosen daemon, or start all enabled daemons if no target is specified
stop disable and stop the chosen daemon, or stop all daemons if no target is specified
restart stop and then enable and start the chosen daemon, or stop all daemons and then start all enabled daemons if no target is speci-
fied
RETURN VALUES
0 completed succesfully
1 an error occurred
FILES
/usr/libexec/xgrid/xgridagentd
agent daemon
/usr/libexec/xgrid/xgridcontrollerd
controller daemon
/System/Library/LaunchDaemons/com.apple.xgridagentd.plist
agent launchd control file
/System/Library/LaunchDaemons/com.apple.xgridcontrollerd.plist
controller launchd control file
EXAMPLES
Print status of agent and controller:
$ xgridctl status
Start the controller and set it to run at startup:
$ xgridctl controller start
Stop the agent and set it to not run at startup:
$ xgridctl agent stop
SEE ALSO xgrid(1)launchd(8)HISTORY
This program was first introduced in Mac OS X 10.4 "Tiger". It was inspired by apachectl(8). The "on" and "off" actions were deprecated in
Mac OS X 10.5 "Leopard".
BUGS
Bug reports can be sent to bugreport.apple.com
Mac OS X April 2, 2009 Mac OS X
Manufacturer Links
General Information
Home Page: IBM United States
Documentation/Information: IBM System p - UNIX servers: Support and services
pSeries and AIX Information Center
Developerworks AIX Wiki: AIX Wiki
AIX for System Administrators
In-depth information from IBM:
IBM... (0 Replies)
Not sure if anyone is interested but I am just getting into UNIX like shell scripting...
I have great interest in pseudo-animations in text mode and accessing HW like /dev/dsp for example...
...
Have fun, I do... ;o)
# !/bin/sh
#
# Bargraph_Generator.sh
#
# A DEMO 6 bit coloured... (0 Replies)
For a starter I know the braces are NOT in the code...
Consider these code snippets:-
#!/bin/bash --posix
x=0
somefunction()
if
then
echo "I am here."
fi
# somefunction
#!/bin/bash --posix
x=0
somefunction()
if (2 Replies)
For those interested in installing dash shell on OSX Lion to help test POSIX compliancy of shell scripts, it is quite easy. I did it like this:
If you don't have gcc on your system:
0. Download and install the Command Line Tools for Xcode package from Sign In - Apple *
1. Download the dash... (2 Replies)
Hearing Aid...
Hi folks yet another bizarre piece of code that is Apple OSX 10.12.x to at least 10.14.1 specific.
It requires only a default OSX install, and the internal microphone along with an external headphone assembly.
Pre-amble, 14-02-2019:
For over 3 weeks now I have been suffering a... (3 Replies)
What is the point of this? Whenever I close my shell it appends to the history file without adding this. I have never seen it overwrite my history file.
# When the shell exits, append to the history file instead of overwriting it
shopt -s histappend (3 Replies)
Greetings,
I'm trying to delete a file with a weird name from within Terminal on a Mac.
It's a very old file (1992) with null characters in the name: ââWord FinderÂŽ Plusâ˘.
Here are some examples of what I've tried:
12FX009:5 dpontius$ ls
ââWord FinderÂŽ Plusâ˘
12FX009:5 dpontius$ rm... (29 Replies)
I have to print the number of stars that increases on each line from the minimum number until it reaches the maximum number, and then decreases until it goes back to the minimum number. After printing out the lines of stars, it should also print the total number of stars printed.
I have tried... (13 Replies)
Hi all...
Well guys and gals, I jumped in at the deep end and found things that PERL cannot do by default.
Many tricky terminal escape codes are not catered for so I had to create workarounds.
One thing I searched for was this:
Passing perl variable to shell command
AND, @Neo this was... (15 Replies)
Well, guys I saw a question about GOTO for Python.
So this gave me the inspiration to attempt a GOTO function for 'dash', (bash and ksh too).
Machine: MBP OSX 10.14.3, default bash terminal, calling '#!/usr/local/bin/dash'...
This is purely a fun project to see if it is possible in PURE... (3 Replies)
I am sharing a code snippet.
for (( i=0; i<=$(( $count -1 )); i++ ))
do
first=${barr2}
search=${barr1}
echo $first
echo "loop begins"
for (( j=0; j<=5000; j++ ))
do
if } == $search ]]; then
echo $j
break;
fi
done
second=${harr2}
echo $second (2 Replies)
Hi All,
I'm having a python script: test.py in /path/to/script/test.py
I'm using a properties file: test_properties.py (it is having values as dictionary{}) which is in same DIR as the script.
Sample Properties file:
params = {
'target_db' : 'a1_db'
'src_db' : ... (15 Replies)