Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

pacemaker(8) [osx man page]

PACEMAKER(8)						    BSD System Manager's Manual 					      PACEMAKER(8)

NAME
pacemaker -- clock drift adjustment daemon SYNOPSIS
pacemaker [-d drift] [-b] [-e error] [-a interval] [-i] [-v] [-n] DESCRIPTION
pacemaker adjusts the system clock periodically to compensate for clock drift. The clock drift is normally computed by ntpd(8), which writes a clock drift value in /var/db/ntp.drift. By default, pacemaker will call adjtime(2) once per second to slew the system clock. The daemon is started by launchd(8) only when the drift file is present or has just been created in the file system. pacemaker detects changes in the file and re-calculates clock adjustment values appropriately. The daemon will exit if the drift file is deleted and is not re-created within one minute. As a fail-safe mechanism, pacemaker will reset the system clock using settimeofday(2) if the system clock requires adjustment exceeding the maximum value that can be accomodated by adjtime to slew the clock. In practice, this extreme case should never occur. The -d option allows the specification of either a floating-point drift value, or the path name of an alternate drift file. If a floating point drift value is specified, pacemaker will use the given value and will not read a drift file. To reduce power consumption, especially when the system is using internal battery power, it may be desirable to reduce the frequency of calls to adjust the system's clock drift. The -e and -a options, together with the -b flag allow several ways to control the clock adjustment fre- quency. The floating point value following -e specifies a maximum error tolerance in seconds for the system clock. For example, a value of 0.001 specifies that the clock drift adjustment should only be done frequently enough to keep the system clock error within one millisecond, based on the current clock drift rate. Alternatively, the clock adjustment frequency can be specified exactly as a value in seconds following -a. When both -e error and -a interval are provided, pacemaker will choose to adjust the system clock either every interval seconds, or less fre- quently if the clock error will remain within error seconds. The settings for -e and/or -a may be specified for operation of the system while using an external power source, and specified independently for operation using internal batteries. By default, the values for -e and/or -a are used for both power configurations. If the -b flag pre- cedes -e and/or -a, then the following settings apply only when the system is using internal battery power. For example, starting pacemaker with the following parameters will cause it to adjust the clock every 2 seconds when the system is using external power. When running on battery power, it will adjust the clock no more than once every 10 seconds, or less frequently if the clock error remains less than five milliseconds. pacemaker -a 2 -b -a 10 -e 0.005 When invoked on the command-line with -i, pacemaker prints a summary of internal parameters and then exits. The -v flag causes pacemaker to print copies of its log messages to standard error. Note that this requires running the program from the command line rather than from launchd. -n causes pacemaker to run without actually attempting to adjust the system clock. FILES
/var/db/ntp.drift default clock drift file SEE ALSO
launchd(8), ntpd(8), adjtime(2), settimeofday(2). HISTORY
The pacemaker daemon was introduced in OS X 10.9. OS X
March 9, 2013 OS X

Check Out this Related Man Page

ADJTIME(3)						     Linux Programmer's Manual							ADJTIME(3)

NAME
adjtime - correct the time to synchronize the system clock SYNOPSIS
#include <sys/time.h> int adjtime(const struct timeval *delta, struct timeval *olddelta); Feature Test Macro Requirements for glibc (see feature_test_macros(7)): adjtime(): Since glibc 2.19: _DEFAULT_SOURCE Glibc 2.19 and earlier: _BSD_SOURCE DESCRIPTION
The adjtime() function gradually adjusts the system clock (as returned by gettimeofday(2)). The amount of time by which the clock is to be adjusted is specified in the structure pointed to by delta. This structure has the following form: struct timeval { time_t tv_sec; /* seconds */ suseconds_t tv_usec; /* microseconds */ }; If the adjustment in delta is positive, then the system clock is speeded up by some small percentage (i.e., by adding a small amount of time to the clock value in each second) until the adjustment has been completed. If the adjustment in delta is negative, then the clock is slowed down in a similar fashion. If a clock adjustment from an earlier adjtime() call is already in progress at the time of a later adjtime() call, and delta is not NULL for the later call, then the earlier adjustment is stopped, but any already completed part of that adjustment is not undone. If olddelta is not NULL, then the buffer that it points to is used to return the amount of time remaining from any previous adjustment that has not yet been completed. RETURN VALUE
On success, adjtime() returns 0. On failure, -1 is returned, and errno is set to indicate the error. ERRORS
EINVAL The adjustment in delta is outside the permitted range. EPERM The caller does not have sufficient privilege to adjust the time. Under Linux, the CAP_SYS_TIME capability is required. ATTRIBUTES
For an explanation of the terms used in this section, see attributes(7). +----------+---------------+---------+ |Interface | Attribute | Value | +----------+---------------+---------+ |adjtime() | Thread safety | MT-Safe | +----------+---------------+---------+ CONFORMING TO
4.3BSD, System V. NOTES
The adjustment that adjtime() makes to the clock is carried out in such a manner that the clock is always monotonically increasing. Using adjtime() to adjust the time prevents the problems that can be caused for certain applications (e.g., make(1)) by abrupt positive or nega- tive jumps in the system time. adjtime() is intended to be used to make small adjustments to the system time. Most systems impose a limit on the adjustment that can be specified in delta. In the glibc implementation, delta must be less than or equal to (INT_MAX / 1000000 - 2) and greater than or equal to (INT_MIN / 1000000 + 2) (respectively 2145 and -2145 seconds on i386). BUGS
A longstanding bug meant that if delta was specified as NULL, no valid information about the outstanding clock adjustment was returned in olddelta. (In this circumstance, adjtime() should return the outstanding clock adjustment, without changing it.) This bug is fixed on systems with glibc 2.8 or later and Linux kernel 2.6.26 or later. SEE ALSO
adjtimex(2), gettimeofday(2), time(7) COLOPHON
This page is part of release 4.15 of the Linux man-pages project. A description of the project, information about reporting bugs, and the latest version of this page, can be found at https://www.kernel.org/doc/man-pages/. Linux 2017-09-15 ADJTIME(3)
Man Page