Darwin(8) BSD System Manager's Manual Darwin(8)NAME
This utility is DEPRECATED. Please use pfctl(8) instead.
Darwin September 27, 2012 Darwin
Check Out this Related Man Page
SystemStarter(8) BSD System Manager's Manual SystemStarter(8)NAME
SystemStarter -- Start, stop, and restart system services
SystemStarter [-gvxdDqn] [action [service]]
The SystemStarter utility may be used to start, stop, and restart the system services which are described in the /Library/StartupItems/ and
The optional action argument specifies which action SystemStarter performs on the startup items. The optional service argument specifies
which startup items to perform the action on. If no service is specified, all startup items will be acted on; otherwise, only the item pro-
viding the service, any items it requires, or any items that depend on it will be acted on.
During boot SystemStarter is invoked by rc (see rc(8)) and is responsible for starting all startup items in an order that satisfies each
start start all items, or start the item that provides the specified service and all items providing services it requires.
stop stop all items, or stop the item that provides the specified service and all items that depend on it.
restart restart all items, or restart the item providing the specified service.
OPTIONS -g graphical startup
-v verbose (text mode) startup
-x safe mode startup (only run Apple-provided items)
-r keep running after last startup item completes, in graphical startup only
-d print debugging output
-D print debugging output and dependencies
-q be quiet (disable debugging output)
-n don't actually perform action on items (no-run mode)
Unless an explicit call to ConsoleMessage is made, SystemStarter examines the exit status of the startup item scripts to determine the suc-
cess or failure of the services provided by that script.
In Darwin it is preferable to create custom startup items than to modify rc, and at some point SystemStarter may entirely encompass the role
/Library/StartupItems/ User-installed startup items.
/System/Library/StartupItems/ System-provided startup items.
SEE ALSO ConsoleMessage(8)rc(8)
The SystemStarter utility appeared in Darwin 1.0
SystemStarter was extended in Darwin 6.0 to support partial startup and interprocess communication.
Darwin April 12, 2002 Darwin
i am setting up a BSD firewall for the first time. I have recompiled the kernel and all that, but am having trouble building a good ruleset. I have read the manpages but am still having trouble creating what I need. It is either nothing is going through or everything is. Does anybody know of a... (3 Replies)
I have a Pentium 100 (32 MBRAM) with FreeBSD 4.4 installed on it and I am using it as a gateway. When I am downloading (or uploading) stuff simultaneously I see that natd is using up to 100% of the cpu capacity, hence the internet connection becomes blocked.
My guess is I will have... (1 Reply)
Right now, my computer is connected directly to the internet.. but I recently got another one, and now I want to use this to share my internet connection to the other one.
The new one has openbsd installed..
How should I do?
I also need to forward connections on some ports to my old... (4 Replies)
i am running nat on my freeBSD and web/ftp server.
The rule allow ip from any to any must always be? or how? if i accept all packets to go on my ep0 which diverts all to my intranet it doesnt help, must the rule allow ip from any to any always be ?
even if many rules are between divert rule and... (3 Replies)
I have a small problem, there is one Win98 PC on our network, and I would like to map the FTP server that we have as one of the Win98's machine's local drives. I am by no means a Windows expert, instead my area is *NIX. The webserver is just a regualar webserver, within the LAN. I tried... (18 Replies)
Because ppp deamon by no means reconnect if connection droped i try mpd. Mpd successful recoennct and all works fine except one problem, MSN messenger can't sign in (error 81000360). With ppp deamon msn works good.
With mpd and ppp have exactly firewall settings "OPEN"...
Where is the... (4 Replies)
I want to setup AP using an NETGEAR WGR614 54 Mbps 802.11g Wireless Router
The router works fine, but I don't have internet access. I will describe the structure of the net to explain it:
I have one server (Free BSD 7) with 2 LAN PCI cards:
re0 - it is connected to my ISP
... (2 Replies)
I have a PF Firewall running on Freebsd v6.x Now I would like to change and review the config in my rc.conf file via a browser . So my approach here would be:
- make a script , which changes for instance the default route
- have this script built-in a Webpage and have a form... (9 Replies)
I have a new FreeBSD 7 web server that connects just fine from the INTERNET side. I'd like to be able to keep that connectivity and then have "authorized" users able to access and be served documents from the INTRANET side. My Firewall works so good, that when I connect from the INTERNET side,... (3 Replies)
While running shell script i got following output.
interpreter "usr/bin/ksh" not found
sh: step1.sh: not found.
ldnhpux | oracle >echo $?
- Running command "which ksh" retruns "usr/bin/ksh".
- I found some information on web stating to remove extra carriage return chars,... (8 Replies)