MOUNT_URL(8) BSD System Manager's Manual MOUNT_URL(8)NAME
mount_url -- mount a remote file system given a URL
SYNOPSIS
/usr/libexec/mount_url [-nrw] [-o options] URL node
DESCRIPTION
The mount_url program mounts a remote file system, specified by URL, on node.
The options are as follows:
-n The mount should be done through the NetAuth agent.
-o Options are specified with a -o flag followed by a comma separated string of options. See the mount(8) man page for possible options
and their meanings. The following option is also available:
soft Make the mount soft.
-r The file system is to be mounted read-only. Mount the file system read-only (even the super-user may not write it). The same as the
``rdonly'' argument to the -o option.
-w The file system object is to be read and write.
SEE ALSO mount(2), umount(8)Darwin April 23, 2007 Darwin
Check Out this Related Man Page
MOUNT_FTP(8) BSD System Manager's Manual MOUNT_FTP(8)NAME
mount_ftp -- mount a FTP filesystem
SYNOPSIS
mount_ftp [-i] [-o options] ftp://host[:port][/path] node
DESCRIPTION
The mount_ftp command mounts a FTP-enabled server directory at ftp://host[:port][/path] at the mount point indicated by node.
If the -i option is not used, all the required information to establish a login to the remote server must be available in the ftp URL,
including username & password if needed.
The user ID for all files and folders is set to the user's real user ID. The group ID for all files and directories is set to unknown, and
the permissions default to read and execute for user, group and other.
The options are:
-i Interactive mode, you are prompted for the username and password if you did not supply one in the url.
-o Options passed to mount(2) are specified with the -o option followed by a comma separated string of options. See the mount(8) man
page for possible options and their meanings. The rdonly option will be set even if it was not specified because mount_ftp does not
allow files to be opened with write access on servers.
ftp://host[:port][/path]
The FTP-enabled server directory to mount as a volume. If port is not specified, then port 21 is used. If path is not specified, then
the path "/" is used.
node Path to mount point.
EXAMPLES
The following example illustrates how to mount the FTP-enabled server directory ftp.apple.com/ at the mount point /Volumes/mntpnt/
mount_ftp ftp://ftp.apple.com/ /Volumes/mntpnt/
SEE ALSO mount(2), unmount(2), mount(8)HISTORY
The mount_ftp command first appeared Mac OS X Version 10.2.
RETURN VALUES
0 mount_ftp successfully mounted the server directory.
[ENOENT] The server directory could not be mounted by mount_ftp because the node path is invalid.
[ENODEV] The server directory could not be mounted by mount_ftp because it is not FTP-enabled or because it does not exist, or
because node does not have proper access.
[ECANCELED] The server directory could not be mounted by mount_ftp because the user did not provide proper authentication credentials.
BUGS
mount_ftp only supports mounting read-only.
Mac OS X June 6, 2003 Mac OS X
Manufacturer Links
General Information
Home Page: IBM United States
Documentation/Information: IBM System p - UNIX servers: Support and services
pSeries and AIX Information Center
Developerworks AIX Wiki: AIX Wiki
AIX for System Administrators
In-depth information from IBM:
IBM... (0 Replies)
Not sure if anyone is interested but I am just getting into UNIX like shell scripting...
I have great interest in pseudo-animations in text mode and accessing HW like /dev/dsp for example...
...
Have fun, I do... ;o)
# !/bin/sh
#
# Bargraph_Generator.sh
#
# A DEMO 6 bit coloured... (0 Replies)
For a starter I know the braces are NOT in the code...
Consider these code snippets:-
#!/bin/bash --posix
x=0
somefunction()
if
then
echo "I am here."
fi
# somefunction
#!/bin/bash --posix
x=0
somefunction()
if (2 Replies)
For those interested in installing dash shell on OSX Lion to help test POSIX compliancy of shell scripts, it is quite easy. I did it like this:
If you don't have gcc on your system:
0. Download and install the Command Line Tools for Xcode package from Sign In - Apple *
1. Download the dash... (2 Replies)
Hearing Aid...
Hi folks yet another bizarre piece of code that is Apple OSX 10.12.x to at least 10.14.1 specific.
It requires only a default OSX install, and the internal microphone along with an external headphone assembly.
Pre-amble, 14-02-2019:
For over 3 weeks now I have been suffering a... (3 Replies)
What is the point of this? Whenever I close my shell it appends to the history file without adding this. I have never seen it overwrite my history file.
# When the shell exits, append to the history file instead of overwriting it
shopt -s histappend (3 Replies)
Greetings,
I'm trying to delete a file with a weird name from within Terminal on a Mac.
It's a very old file (1992) with null characters in the name: ââWord FinderÂŽ Plusâ˘.
Here are some examples of what I've tried:
12FX009:5 dpontius$ ls
ââWord FinderÂŽ Plusâ˘
12FX009:5 dpontius$ rm... (29 Replies)
I have to print the number of stars that increases on each line from the minimum number until it reaches the maximum number, and then decreases until it goes back to the minimum number. After printing out the lines of stars, it should also print the total number of stars printed.
I have tried... (13 Replies)
Hi all...
Well guys and gals, I jumped in at the deep end and found things that PERL cannot do by default.
Many tricky terminal escape codes are not catered for so I had to create workarounds.
One thing I searched for was this:
Passing perl variable to shell command
AND, @Neo this was... (15 Replies)
Well, guys I saw a question about GOTO for Python.
So this gave me the inspiration to attempt a GOTO function for 'dash', (bash and ksh too).
Machine: MBP OSX 10.14.3, default bash terminal, calling '#!/usr/local/bin/dash'...
This is purely a fun project to see if it is possible in PURE... (3 Replies)
I am sharing a code snippet.
for (( i=0; i<=$(( $count -1 )); i++ ))
do
first=${barr2}
search=${barr1}
echo $first
echo "loop begins"
for (( j=0; j<=5000; j++ ))
do
if } == $search ]]; then
echo $j
break;
fi
done
second=${harr2}
echo $second (2 Replies)
Hi All,
I'm having a python script: test.py in /path/to/script/test.py
I'm using a properties file: test_properties.py (it is having values as dictionary{}) which is in same DIR as the script.
Sample Properties file:
params = {
'target_db' : 'a1_db'
'src_db' : ... (15 Replies)